Can not access network shares, net view turns up error 6118, can't set master browser

I’ve been using a wdtv live plus with b-rad firmware for close to two years without issue.  it is connected via ethernet to a gigabit switch which is connected to an e1200 router running dd-wrt firmware.

I use a windows home server to store all my files.  I ran v1 untill a month ago when I changed to whs 2011.  there are a  couple of win 8 computers as well as one win 7 and a few randome devices on the network.  

I have never had any trouble viewing and using network shares untill two days ago.  up untill that point all my pc’s would show under network shares on the wdtv and I was able to access any sharded folders.

two days ago all but one pc was missing.  I read numerous post about the issue and it seems I have a master browser problem.  I found tony’s excelent turioal.   the problem with that is when I do net view on any of my pc’s I get the following

“System error 6118 has occurred. The list of servers for this workgroup is not currently available”

it should be noted that ALL shared folders on the server are accesable from all other pcs!  the only thing that can’t see them is the wdtv.  I can even  “net view \server” and see the sharded folders yet normal net view command shows the 6118 error.

I have set computer bwroser service to automatic on the server and manual on the other machines.  I also did the registry edit to try and force the server to be the master browser 

Double click on MaintainServerList
Set to Yes

I even set it to NO on the other pc’s.  nothing has worked!  sometimes a different pc shows up under network shares but never the server.

the only firewall on any of the machines is the windows one.  all sharing is set to “everyone”, file and printer sharing is on etc.  again I can access all folders from all pc’s just not the wdtv.

Since you’re using WDLXTV, you should be able to shell into the WD.

You can execute the command


which should show you the list of servers that are registered to the master browser.

If it doesn’t work, then you have NO functioning master browser.

Try shutting down every single device on your network except for your router.

Then reboot the server.

The server should certainly be the master browser at that point…  If not, well, there’s something wrong with the server.

1 Like

I tired to go to the webend but I can’t get in via  the default password.  I can’t get the password reset to run either.

Anyway I did get it to work.  Not sure for how long though :wink:

As I said I disabled computer browser service in all other pc’s.  It still wasn’t working.  I then turned everything off & power cycled the router.  I then turned on only the server.  It still wasn’t working.  I did read it could take a little time.  I then turned my main pc back on so I could remote into the server to check everything.  I then made sure my main pc had disabled computer browser and it had.

I went and checked the wdtv and now my server was showing and all the network shares were acceable!  the server was the only one showing even though the main pc was on as well.  that is fine, I can live with that if it stays like that.  I’m just afraid that for whatever reason it will change again.  

should be noted that net view command from the server still shows the 6118 error.  net view \server works.  so I still can’t figure a way to show the master browser.  I assume it’s the server now since it’s working and I disabled the service on the other pc’s.  the server runs 24/7.  the only times I restart are to do updates and I shut down to add hard drives/hardware as needed and to clean out dust every now and then.

The other devices on the lan are a couple of android phones, a kindle fire hd, a squeezbox, and a directv “whole home dvr” box.  would any of those conflict?  Seems like if they were the other pc wouldn’t have shown in network shares.

I really hope it stays working!  We use the wdtv all the time.  My two year old doesn’t understand why she can’t watch Elmo cause daddy is troubleshooting network issues :wink:

the wdtv has been working since my last post yesterday…  one thing still bothering me is that net view was stil not working on any of my machines.  I was still getting the “system error 6118 The list of servers for this workgroup is not currently available”

also server was the only machine showing up under network shares.  99% of my files are stored on the server but I do share and view my “encodes” folder on my main pc so I can view them on the tv before moving the files over to the server.

so I tried a few more things.  looking in my event log of my home server I see tons (every ten mins for a few days) of NetBT event id 4321 errors

“The name “WORKGROUP      :1d” could not be registered on the interface with IP address The computer with the IP address did not allow the name to be claimed by this computer.errors”

also a number of Browser event id 8020 errors

“The browser was unable to promote itself to master browser.  The computer that currently believes it is the master browser is unknown.”

I went into my router settings and discovered that is my canon network printer.  I deleted the lease and then turned the printer off.  now net view works as does nbtstat -a which list my server as the master browser!  I just went and checked the wdtv and both my server and main pc show in network shares!

so it was the darn printer!  now the question is how to stop this from ever happening again?  the printer is not installed or used on the server.  it is connected via usb to my main pc.  the laptops use it wirelessly.  it generally is always on.  maybe that needs to change but that’s half the point of having a wireless printer is so I don’t have to get up and walk across the house to print from the laptop/couch.

1 Like