Can not access Mybooklive after Windows 10 update 1803

Hi,
I have a MYbooklive NAS and since upgrading my Windows machines to 1803 I can no longer access the shares from the windows machines. The machine see the Mybooklive and can access the UI using the IP but not the files. 1803 removed the Honegroup which I believe is the problem. I can see the files via the internet and via a MAC. I have tried all suggestions, turning on SMB 1 and also trying to create shares via the IP address but doesn’t work. When creating a share using IP it sort of connects but then a Windows Security box appears asking for user is and password. I have tried all the MLB users and passwords plus my windows userid/passwords but nothing works. Help!!

I rebuilt my machine with latest window and now have the same problem.
When trying to mount, it says:

“You can’t access this shared folder because your organization’s security policies block unauthenticated guest access. These policies help protect your PC from unsafe or malicious devices on the network.”

but I cannot find any windows network setting to let it through (have also turned off the firewall etc).

Hi, managed to get mine working last night. This is the order

  1. Reenable SMB1 (in windows features- lots of articles how to do this
  2. Reboot windows machine
  3. Create shares with IP address… you will get the log on message for each share which won’t work, don’t worry
  4. Reboot windows machine
  5. Reboot MYBookLive drive
  6. Reboot windows machine

Shares should then be back… try to access a share and you will be asked for the user is and password. Enter a valid user of your MyBookLive and it will (should) work

Thank you that’s useful.
I see though that SMB1 is obsolete and unsafe (it makes ransomware attacks easier) so I think that I won’t do it and migrate my storage to other clouds e.g. google drive or onedrive (unless WD provide us with an update version of the software that uses the safer file sharing protocols rather than SMB1).

I don’t have a solution for you, but I can confirm that SMB 1 is not needed. I’ve had SMB 1 disabled since I migrated to Win10 2 years ago and have had no trouble accessing either public or private shares on MBL NAS devices.

I’ve never understood either Homegroup or Workgroup but my MBL control panels refer to Workgroup rather than Homegroup and defaults to the Windows default Workgroup name: Workgroup. I have no idea whether that related to your problem or not.

Unless you are trying to access a public share it is appropriate for Windows to prompt for the NAS userid and password. What happens when you enter the userid and password? Are the credentials rejected, or do you successfully log in but don’t have access to the data? If the latter, did you give the userid access to the share you are trying to access? (Sorry if that sounds like a “Is it plugged in?” question.)

It can’t find neither the public nor the private shares: they are just not seen by windows explorer. I have tried typing in \ipnumber, \MybookLive, and also using WD’s own “MyBookLive Public SHare”. It gives the error mentioned above.

Instead using e.g. WD MyCloud or WD Smartware gets through and shows the files.

I found a Microsoft article that addresses this, but I’m not sure I understand it.
https://support.microsoft.com/en-us/help/4046019/guest-access-smb2-disabled-by-default-in-windows-10-server-2016

It has to do with prohibiting “Guest access” to remote shares using SMB2. I had never heard of guest accounts. If either of you are using guest accounts the solution provided might work.

Thank. But no guest accounts… I have just reinstalled windows from scratch, just one user, the machine is very very clean.

Hey, this worked for me

See the section
Ensure the following Windows Services are running and set to Automatic.
Please follow the steps outlined below this list for instructions on how to make changes if needed.

  • Computer Browser
  • DHCP Client
  • DNS Client
  • Network Location Awareness
  • Function Discovery Resource Publication
  • Plug and Play
  • SSDP Discovery
  • Storage Server
  • Server
  • UPnP Device Host
  • TCP/IP NetBIOS Helper
  • Workstation

Pulled out the old XP comp and can now access one LiveBook. The old software won’t load on the Win 10 machines and the latest SW from WD doesn’t work. A SW update is needed or my two drives are toast.

I have been struggling with the same problem for months but found the solution that is much easier that I thought. I typed the assigned name of my device on the windows explorer as follows: \\device-name (NOT THE IP address), clicked enter and got the windows sign-in prompt. Typed my username and password and all is working miraculously. I did not have to change any network settings.

This problem might be related to a Windows 10 change in local group policy to no longer allow “insecure guest logins” to SMB servers, in which case it’s also related to the type of SMB connection. When you mounted the original network drive, it was probably created as a SMB1-type (unsecure) mount and your username and password were cached and stored with it (when you make the mount persistent with stored user credentials). After the upgrade, Windows will try to re-use this cached network connection, but it will fail. As I understand it, you can work around this in a few ways:

  • Re-enable insecure guest logins. See here
  • Delete the network connection and create a new one e.g. using the device name \device-name. Since Windows 10 will no longer allow insecure guest logins, it will now be a SMB2+ mount. The challenge here is to make sure there are no (legacy) stored connections/automatic logins left over/stored Probably also good to ensure no credentials are saved/left over in the Credential store for the old mount.

Hello everyone!
I tried every solution listed here and on Windows forums. The only one that worked with my WDBookLive is this:

After these steps MybookLive appears in “network” sub-folder on the left of win explorer under its ip-address.

Hope it will help.

Best,

I was unaware of this problem until I did a clean install of our two computers to Windows 10 1809. Couldn’t figure out why I couldn’t see MyBookLive. It was a problem because all of the file backups were on it!

I tried all the suggestions in this topic and one other that discussed it. No joy. Finally, I bit the bullet and bought Webdrive. Not an elegant or cheap solution but at least I have access to it until I can find a better solution. HTH

YOU ARE Amazing!

I have tried for ages getting this to work (ie accessing my MBL files. Came across your post. Tried it and it worked!

THANK YOU THANK YOU THANK YOU.

Regards
Byron
New Zealand

Hi all,

I followed [Ki_Ki_Ki] guide but for me this doesn’t work. Are u still accessing to your mybooklive enabling this properties of gpedit.msc?

Thanks,
Ema