Can no longer see all media files after firmware 5.27.157 update

I am wondering if anyone else has this problem or a fix. I had to roll back firmware to see all of my files. After 5.27.157 update on all 8 of the external hard drives attached to the EX2Ultra, only a few files and folders are visible, even though the size used and free is showing correct readings. So, I know my files are there, but they are not visible and therefore not able to be used by my PLEX server. After I rolled back the update, all files are visible. I went through this process twice just to double check the results with the same findings. Files are not visible once 5.27.157 is updated. I hope there will be a fix to this system update as it appears to have many issues. Thank you for your help in advance.

I do not think it is an app issue as I cannot even see the files directly on my Mac in a finder window. Plex is updated. Like I mentioned, I tried installing the update twice. Both times the files are not showing in finder.

You were lucky, I lost the RAID configuration due to the FW update, and consequently all data. Besides some lukewarm references to knowledge base articles, no help from WD support. Time to move to QNAP.

Western Digital needs to pull this firmware and test it further if there are all these issues. It is for sure a disappointment.

if commonly used addons like Plex and Samba are broken by the firmware. . . .with no updates to those apps available. . . . then that is a bad thing.

Again, it has nothing to do with PLEX. I cannot see my files just using Finder on my Imac. I don’t understand this issue. I have 8 external hard drives connected by usb on the back of the ex2ultra.

I don’t dismiss you. I just don’t understand… I just want to plug my hard drives into my ex2 ultra and see my files the way I should. It’s not an app issue and has nothing to do with plex at all. That much I know. I just want to know why my files don’t show up and when will WD fix this issue.

Not to get in an argument, but i didnt think os5 supported usb hubs?

Hi, I read your articles and they show you are very knowledgeable of the inner workings of the MyCloud NAS. Now I see you pulled your comments. Anyway, in my situation, with the 2 disk EX Ultra, nodisk errors are shown, I have full access to the dashboard and ssh, but capacity is 0kb, and installed apps don’t pop up when selected. The error message only reports “no RAID configured”. Interestingly, the file wd_nas.conf only shows [Globa], which seems odd. Any ideas would be highly appreciated!


USB hubs has worked in OS5 for me for a long time. WD Picks up the hub and all hard drives, just does not show all the files on the hard drives. Some files do show up while others are just missing.

Cerberus, Why do you keep deleting your posts. Couldn’t look back at them for help if needed too.

I don’t live on the computer here. So check things when I can. Anyway, thanks for your help.