Can I just format my WD Mybook 3TB so it behaves as a generic USB drive?


First, I must state I LOVE my WDTV live!  However…my relationship with WD external drives has not been as good.

I have avoided them for years due to all of the extra software it used to need to work but received one as a gift. 

I am using this USB 2/3 device with the provided cable into a USB 2 port on a fairly powerful but pre-USB3 Windows 7 64 bit machine…

I have read the FAQ and posts but my problem is a bit different.  My drive is “usually” recognized by my PC.  Of course since my intent is to use it as a backup drive, that is a concern. I know the faq talks about PC issues as perhaps being one of the reasons, but EVERY other external drive I plugged in always worked and still does- every time.  And none of them try to re-install drivers every time you plug them in.  The WD drive, I plug it in, and every time it installs the 2 generic USB drivers successfully and then the “special” WD driver of course fails because it is not included in windows. I understand that and no, I have not tried to install the special driver as I don’t have any intention of using the WD software.  And quite frankly, I don’t want to risk messing up my other hard drives just to get a WD drive working.

Then sometimes I plug in the drive and it is says it is unrecognized. So not just the third driver fails but the whole drive is not seen by windows.  Again, I have read the posts on this but mine does not do it every time. I unplug, replug, and usually it will work. Almost like it is a timing issue.  Once it says the drive needs ot be formatted…and then seconds later, the “windows option” box popped up asking if I want to browse the hard drive.

It behaves similarly on two other PC’s.

So my question is this. If I just re-format the drive, will it behave like a normal generic drive?  Or is there something in the hardware that is still going to look for special drivers, etc.  Do you think that will solve the issue?

Any help appreciated. 




I recommend you make sure the drive is plugged in into a wall outlet. Avoid any power strips, surge protectors and extension cords. A power issue might be the cause to this experience.

About the SES driver I recommend you read the information found in the link below:

What is the SES driver, why is it needed, and how to get the driver popup to stop 

Thanks for that.  I did indeed peruse the support page before posting and saw that item about the SES driver.

As far as power, in order to provide safe power to my external drives. I use a surge protector powered by a UPS.  No other drive  that I plug in there has issues.  For testing purposes I guess I can plug directly in the wall but this does not make sense to me to bypass surge protection and a UPS…

Back to my original question. If I format the drive, does the SES driver prompt go away and will it behave like a generic USB drive?  So is that a software thing or is it embedded in the hardware?  I totally understand I can install the driver and/or make the popup stop. But the point is that I need to use this drive with multiple PC’s and I do not intend to install the drive and/or stop the popup on all of them…and every new PC that I might get and plug the drive into.

Also, is there a “known issue” with these USB3 drives being plugged into USB2 ports?  Seems like more people have this issue running them under USB2 (which it says should work).  FWIW I have 2 other USB perpherals that work as USB2 or USB3 and they work fine.



Can anyone provide input as to if I re-format this drive it will still ask for an SES driver?

I plan to use a UPS on all my external drives.  If a WD drive cannot be used with a UPS and needs to be plugged into a wall, I would not consider it a safe bet for backups which could be corrupted.  But for testing purposes I will try once I get a response on the SES driver issue and perhaps if it acts like a normal drive and does not fail while trying to install the non-existant SES driver in windows…perhaps it will just appear as a drive when I plug it in and not re-install drivers every time. 

Any input most appreciated. Thanks,


It appears from my research elsewhere that all of the above is built into the controller, etc. and the format will not do anything. Based on the lack of response here I am going to pull the drive out and put it in another enclosure. I can’t have a drive that cannot be plugged into a UPS and cannot be reliably recognized immediately by every PC I plug it into…