Can any one help me my issue is different from all

hello every one.
I am Dhaval from india facing strange issue with my WD MY POASSPORT ULTRA 1TB.
here is my problem
1) in disk management my hard disk shown up as DISK 1 .unallocated space and
simple volume only not initialized .NO SIZE OF ANY USED OR OTHER SIZE
SHOWN UP.(so many attempt made to INITIALIZED disk but not succesfull)
2) after so many attempt usb attach/detach it shows initialize disk but it fails.
3) while my HARD DRIVE Shows up in WD UTILITY SOFTWERE with its serial no
and softwere version and other detail only but NO DISK SIZE .
4) even tried to erase it but can not perform it too.
5) softwere is also UP TO DATE
6)even can not reboot it.it shows I/o error.
my cable is working good also tried with change cable,
and no physical damage to my drive.
some time LED light keep blink ,disk rotate too.
some time LED just lighten up not BLINK.

wd

posting in the correct forum is the first step … this is the My Passport Wireless forum

Portable USB Hard Drives forum is here … https://community.wd.com/c/wd-external-drives/wd-portable-drives/25

anyways, i have no idea what the hard drive issue is … does not look normal. If it’s new, check the warranty status and submit an RMA for a replacement.