Bugs in MyCloud OS5 PR4100

Dear WD community,

since I had to upgrade my PR4100 form OS3 to Os5 I do experience some problems. As I posted in other blogs, the upgrade function form OS3 to OS5 did not work smoothly. All user access permissions got into trouble and I was unable to fix most of the problems. The “indexing forever error” has been solved by WD firmware updates, but some other problems are new or remain so I would like to ask whether other users experience the same problems.

All problems described below occur with the latest firmware available:

Firmware: 5.09.115

The whole system was set back to factory defaults before installing new users / new shares.

User groups:

I defined user groups that I assigned to different users. But when the users logged in, no connected shares (“read only”) were visible. When setting the “read only” of the users’ groups’ shares to “write access” these shares became visible and remained visible also after switching back to “read only”. But whenever a new user was assigned to the groups’ shares, the whole procedure of switching access rights had to be repeated to make the shares visible.


For some unknown reasons I could not activate the cloud access via user invitation email. “An error has occurred. Please make sure that you are connected with the internet.” This error message ist confusing because internet access was possible all the time. It remains unclear why some users could get access, and some did not.

When using OS5 all users have to create a new WD account via os5.mycloud.com. For some users this worked out fine but for some unknown reason it did not work. (Error messages “access denied” / “There is no device assigned for your account”). I could solve it by removing the users and starting again to set them up in the PR4100’s web interface. It remains unclear why it failed at the first attempts.

For one user sending in invitation email was impossible. When choosing a different email address for the user it worked out fine. It remains unclear why the email-invitation function seems to reject a specific email address.

Accessing the web interface via external network

My PR4100 is working in a professional environment and I can access the device vis it’s TCP/IP number. But the device has another unique WWW TCP/IP address form outside my department. In former time I could get access to the dashboard via this function to administer my device from home when not being at work. With the update from OS3 to OS5 this function does no longer work. Access ist possible but the dashboard is not shown. This means that access with a different TCP/IP number other than that specified in the TCP/IP setup is no longer possible. It might be that the HTTP implementation has an error.

But: The external access via the external TCP/IP number is working and can e.g. be used by “Goodsync”, but the dashboard does not become visible.

It seems to be a secret who access for new users is managed via the os5.mycloud.com webpage. Some information must be stored at WD to match email address and device. If some male information ist stored at WD the users are unable to delete this information.

Port forwarding

I tried to forward some ports to make sure that external and internal FTP / HTTP are working. (eg. FTP external 20 to internal 20, HTTP external 80 to internal 80). But the status of port forwarding is always “error” (what was not true in OS3). I made sure that nothing is blocked by the firewall of my professional environment. What was working with OS3 is no longer working with OS5.

Unwanted emails

When a new user got access to the same shares as users who were already using them, the existing “old” users were informed via email that a new users became access. The “old” users ware no admins and it does not seem to be possible to stop this emails.

Missing “browsing app”

In the former OS there was an option to browse all shares form the dashboard and to make changes to the data. This function is no longer available.

UBS backup tool

The USB backup tool did not work as intended. Before setting the PR4100 back to factory defaults I copied the data to an external hard drive connected to the USB post of the PR4100. After re-installation I wanted to copy the data back to their original position. This was not possible, because the whole data path was added. For example:

\share1\mydata was copied to B20210208\share1\mydata

When I tried to copy it back, I selected “B20210208\share1\mydata” as the source and “\share1” as the destination. But the data was copied to “\share1\B20210208\share1\mydata”.

I could not find a PDF file of the OS5 users’ manual. There only is an online version.

Did anybody else experience my problems as well? Are there any solutions?

Kind regards

Thorsten Frenzel

Did you post this or any ideas you have here? Latest My Cloud OS 5 Personal & Network Attached Storage/Product Ideas topics - WD Community. More people may read it if you do.

Thanks! I added the “Product Ideas topics”