Brand new Passport for Mac not detected by Macbook Pro

I purchased a WD Passport for Mac two days ago.  It lights up and everything but nothing else. I have tried using it on Windows and Linux laptop to no avail. It just lights up , makes “normal” sounds and that’s it. I have tried restarting the laptops, changing the hard drive’s cable, downloading WD drivers, checking Disk Utility but nothing. Can anybody help?


If the drive is not seen when you connect it to your computer then you should try some basic troubleshooting:

1- Disconnect the drive from the computer and restart the computer.

2- If the computer is a desktop, connect it on the back USB port (directly to the computer, not through a hub).


3- Go to "Disk Utility” to verify if the drive shows up there.

If the drive shows up in disk utility but it is not seen on the computer, then it means the partition is corrupted and you will have to format it in order to use it again. Please note that formatting the drive will delete all data stored on it.

Have you read my post at all?


If these troubleshooting steps don’t work then you should get the drive replaced.

How to get an RMA, (Return Merchandise Authorization) or replace a defective product under warranty