Brand new My passport ultra - can't get started on Mac

Trying to format for Mac El Capitan, following instructions and falling at every hurdle. Erase process fails “Couldn’t unmount disk”.
Partition - can’t do - as apply greyed out
First aid - “problems were found with the partition map which may prevent booting”


Make sure you follow the steps provided in the link below.

Thanks, that’s where I got the instructions from and did follow them

Did you get sorted? I’m doing exactly the same problem. Did the erase (I think) but now the partition button is greyed out. Help please… anyone :slight_smile

You know the definition of madness is doing the same thing and expecting the same results? Well in this case it worked…just kept repeatedly doing same thing and then it miraculously worked.

Lol… strangely enough, partition is now an option so I’m now trying to apply so thanks for that, I’ll just keep trying to apply. Jeez, who knew this could be so difficult. Only want to store photos on an external to save space on my hard drive. I’m new to Mac and not a techie which isn’t helping but getting there slowly. Thanks for the quick response :slight_smile: