Box continuously resets itself... gets to "loading osd", then resets

I have used this unit a lot over the last couple of years, and was up to date on firmware (I think).  But today it reset and keeps resetting.  I did a power off, then did a reset with the button on the bottom.  No joy.

Has this unit finally given up the ghost?  Or was there a firware update today that could have somehow hosed it?  I didn’t see one and didn’t do an update, but this is a bad situation. 

Hello, try disconnecting the WDTV power cable for at least 15/20 seconds, if you have it connected to a power strip, connect the power cable directly to the wall instead. 

1 Like

Thanks, but I did try that as well, had it disconnected from power for at least an hour.  I did not try plugging it into the wall directly, I think it is on a power strip.  But, it has been on that same power strip for months.

Try a hard reset (unplug from back of unti) and while it is loading continually hit the setup button.  If you’re lucky, you can get that screen and scroll to the reset button (to set back to factory defaults).

I’ve read this has worked for some stuck in the same reset loop you’re in. 

Good luck.

1 Like

Oh… Kay… so I unplugged it from the power strip and directly to the wall.  And it booted up.

I am not calling this “solved” just yet, I want to see if maybe it is just flaking in and out.  But will come back after a few on/off cycles and report back if that actually was the problem.  Considering that it has been plugged into a power strip for 2 years and I’ve never had a problem with it… I would not only be surprised if that was the issue, but would love an explanation as to why.

Bloodshot, if I see the problem again, I’ll try your suggestion.

I am reluctant to call this issue solved, because that is a sure-fire way to make it happen again. 


But it has been powered off/on a few times now, and seems to be working as before.  So the only thing I did was plug it directly into the wall.  :shrug: