BitLocker (Windows 7 SP1 64-bit) fails with WD My Book 4TB USB

I had a good result using BitLocker (Win 7 SP1 64-bit) with another brand of external USB hard disk (3TB) but nothing but problems with WD My Book (4TB).

Sometimes BitLocker says that encryption setup has been paused and the ‘resume’ key doesn’t do anything.

Another time it says “a device attached to the system is not functioning” – that I got around by reducing the partition size by 5GB; but then got stuck again later if the encryption process was paused (as is likely since computer sleeps, or my kids log on during the days it takes to encrypt a 4TB drive!)

I’ve taken the drastic step of wiping the disk and starting from scratch; but still having problems.

Anyone experienced similar, and found a solution?

Is it BIOS related (I use a Gigabyte Motherboard GA-Z68X-UD3H-B3 rev. 1.0 with latest BIOS)?

Is it Microsoft problem (but other drives have been fine)?

Is it a WD drive issue (interference with built-in encyrption system)?

Thanks in advance for your help,


Hi AndrewRH, do you experience any problems when copying files manually into the My Book? Check if you have the latest USB 3.0 drivers for your PC, you can also try connecting the My Book to another PC and verify if the same problem happens. 

Thank you for that reply.

No, had no problems copying files onto the drive; even ran a chkdsk and it passed. Defrag too for what it was worth.

Yes, tried on my work computer too and the same issue - it did not resume encryption.

When took drive back home, and it still didn’t resume encryption, that is when I tried making the partition ever so slightly smaller – which got it to start encryption; but as soon as it was paused (eg when my kids got onto the computer) then it would not resume.