Beware of latest Gen1 firmware update


#1

Below is a tech support request I sent to WD. Might be relevant if you have a device with multiple drives.

I have had a WD TV HD Media player (generation 1) installed for about a week and am very happy with the performance. I do have an issue that has me puzzled.
I did the firmware update to version 1.03.01 and want to revert back to the previous version. I have a Sandisk Fuse MP3 player with a separate slot for a micro SD card. Before the update I was able to plug in the player and the WD TV box saw both drives and I was able to access either and play the content on each one. After the update it does not see the SD card, only the built in memory. If I take the card out and put it into an external reader is will function normally in the WD TV player. How do I get the previous firmware version back in the WD TV? I cannot find it in your archives. Having the ability to see both drives in my MP3 player is important to me and updates are supposed to add features not take them away.

My response from WD is sorry, once you upgrade the firmware you can’t go back. Thanks guys, I just might return it.  Nice to see that they have thoroughly tested their firmware.


#2

There is another reason to beware of the new firmware.  If you use you WDTV as a music player the new firmware will render it essentially useless for this purpose.  After upgrading to version 1.03.01 you will no longer be able to shuffle between all the tracks within a genre or by a particular artist.  You can only shuffle between tracks in the deepest subfolder, which will likely be by album.  If you want to be able to shuffle among various tracks by various artists or on various albums DO NOT INSTALL THE NEW SOFTWARE.  As the previous post indicated, you can’t go back.  Let’s hope WD fixes this quick.  Otherwise I’ve wasted my time and money, as I can get the same music playing capability from a single disc CD player. 


#3

Updated this morning and lost my multi drive capabilites. Found a link to the older version so am going to try to revert back. Here’s the link if you want to try also. http://support.wdc.com/download/wdtv/WDTV_FW_1_02_07.zip


#4

In order for the system to recognize the older files, you have to open the wdtv.ver file and rename it 1.03.02

Restart your system and it will start the process. Delete the files from the drive as soon as it’s done or it will try to go thru the process again since the system will have been reverted to the 1.02.07 files and it will still see the newly renamed 3.01.02 file.


#5

First off, you can most certainly revert back to older firmwares! Secondly, if your WDTV does what you want it to do, DONT upgrade… dont fix it if it is not broke…lol I have 2 Gen 1’s, and they are running firmware 1.02.7 and it does everything I need it too… play 1080p movies perfectly with cover art. I just bought 2 WDTV lives, and they work just fine, apparently a new firware for that one is causing problems??? I only add firmware if something really needed is added, like when they added cover art for mkvs… if you read the rellease notes, there hasnt been anything really significant in a long time…

Anyways…sorry for the rant… all you have to do to revert to old firmware is rename the wdtv.ver file(open with notepad) firmware that worked for you, or download it, and rename the file version with notepad to a higher number than the current one installed…only then will the player see it… so if you have 1.03.01 just name it 1.03.02 and it will tell you new firmware detected… Any questions, let me know… I have been testing these players for a long time:)

*Edit-Seems JudyP beat me to the punch while I was typing… The main reason I stayed on 1.02.07 is that this version was the last firmware to suport usb hubs!! i have a 4 port usb  hub, so all together i have 5 drives hooked up to one player, and it can read from all 5TB;s just fine:)


#6

Is there some place on this forum where one can report this bug? I would really like to have the play by genre/artist/etc feature fixed instead of going back to the old firmware


#7

hi can you tell me how i can get the old firmware 1.02.07


#8

I included a link in my post above to the old software.


#9

Thanks I put it in the WDTV and it only seeing 1 hard drive and I have 4 what can I do.


#10

I agree with Rominacampos, there should be a place to report this bug as it isn’t just an isolated occurrence.

I too have a problem after updating the firmware in the WD HD Media Player it now has issues reading my External Storage Device. I have a Nexstar MX (NST-400MX S2) dual bay enclosure with two 1TB Samsung hard drives. The older firmware 1.01.02 read both bays perfectly, although it is one USB connection it saw both hard drives and showed them as two separate entities. Firmware 1.02.07 and above only recognizes one of the hard drives and I am unable to access the other one. Initially I thought it was an issue with the Dual Bay Enclosure, but it still works fine when connected to the PC showing both hard drives as separate entities. I know it worked with the original firmware, so something has changed in between.

I emailed the WD support and they responded initially with a list of compatible hard drives. When I told them that my hard drive had worked previously I got the response of “Thanks for your feedback”.

I know I can revert back to the older firmware, as posted here, but would also like a solution in the newer firmware.

Surely they know what was changed to stop the unit seeing multiple hard drives.

Is Western Digital aware of everyone’s concerns?


#11

I try the steps but it doesn’t seem to recognized the change version.  What I am doing wrong?


#12

Can some one help as I never updated my firmware and  as i tried to follow teh instruction i cannot see any update firmware icon on the setting menu kindly help. 


#13

You have to fool the wdtv thay you have a newer firmware. If you have 1.03.01 installed and want to downdrade, all you have to do is make a change in the vdtv.ver -file.

Change the version to 1.03.02 and the wdtv think it’s a newer firmware even if it isn’t.

When I upgraded to 1.03.01 from 1.02.07 my 8GB USB-stick stopped to work and I could only see one of my two disks in my external storagebox.

Now back to 1.02.07, and everything back to normal.

How can they release a firmware that don’t work!?!


#14

Dear WD support,

Generation 1

Were still waiting for your response regarding this issue.

Just to add:

Is there ay upgrade firmware that can resolve this issue in WD TV generation 1. Hope ypu can help us to fix it.

Thanks in advance

Regards,


#15

HELLO WD COMMUNITY, JUST WANTED TO SAY THANK YOU FOR THE POST ABOUT THE FIRMWARE UPGRADES FOR THE MEDIA PLAYERS. I WISH I HAD FOUND THIS BEFORE I DECIDED TO UPGRADE. I ONLY UPGRADED BECAUSE IT WOULD NOT PLAY SOME OF MY MOVIES. HAD I KNOWN THAT AFTER UPGRADING IT WOULD NOT PLAY A LOT MORE OF MY MOVIES I WOULD HAVE NEVER UPGRADED. I’M GOING TO DO WHAT JUDYP SAYS TO DO AND HOPEFULLY IT WILL WORK ONCE AGAING THANKS.


#16

:dizzy_face:  PLEASE PRESS YOUR CAPS LOCK KEY BEFORE YOU TYPE!

Like this , please.

On the Internet, it’s considered “yelling” to type in all-caps.

Thank you.

And to get on-topic, so far I haven’t had any problems with 1.03.01 firmware. We’ll see. It’s certainly better than the latest firmware on the Gen 2 model (caused major audio sync problems with some files).


#17

At last! After many emails with WD support, I have downgraded my WD TV to previous version 1.02.07 thanks to post from JudyP. It’s disgusting that support just say to change HDs, reformat and things like that. I have had many problems with different HDs since I updated to the latest firmware 1.03.01.

Now, noticing that this is a general issue, I am not able to understand why the update is still in the WD site to download. “Amazing” support for a brand like this…

Maybe WD should consider to change Support Team (probably from another company like Phone Operators do) to real WD techs who know what they are doing. I really think that most active users of this forum would be good candidates.

Thanks Community for such a support.


#18

I have a problem with my WD TV HD Media player 1 gen and I have the latest firmware 1.03.01 installed. The problem I have is that all .avi movies I watch “microstutters”. If I play .mkv movies it works just fine but lately I had this annoying problem with .avi movies. I’ve tried to format my external hard drive and to downgrade the firmware but nothing seems to work. What to do?


#19

I learned a hard lesson…always read the forums before doing ANYTHING to your WD TV.  Thanks to JudyP and WD Forum Ninja for their excellent advice.

These DETAILED instructions are on how to revert back to original manufacture’s firmware when using a DUAL-DRIVE USB Enclosure with two physical drives reading as separate physical drives on their WD TV (Generation 1).  This is NOT for BIG-configured drives in a dual enclosure.

Here are the steps in sequence:

  1. Cut and paste the link JudyP stated ( http://support.wdc.com/download/wdtv/WDTV_FW_1_02_ 07.zip) into a new url of your favorite browser and download the link

  2. Go to where the file was saved and open (unrar) the RAR file

(You will receive two files: “wdtv.ver” which directs the WD TV to read the “wdtv.bin” file, and “wdtv.bin” which has the ORIGINAL firmware information that came with the WD TV)

  1. Right click on the “wdtv.ver” and open this file using “Notepad”

  2. Notepad will open this file as a document and you will see, "VERSION=‘1.02.07’ LOCATION=‘wdtv.bin’

(1.02.07 is the ORIGINAL firmware version that came with the WD TV when you purchased it)
5) Change the VERSION=‘1.02.07’ to read VERSION=‘1.03.02’

(The reason for this is that when you updated the firmware on the WD Live, it updated to 1.03.01.  You cannot go backwards in number sequence, only forward.  Therefore 1.03.02 is the next number in the sequence.)

  1. Be sure to save the Notepad file by overwriting the file (don’t change the file name).

(When you update the WD TV with this new version 1.03.02, the “wdtv.ver” file will direct the WD TV to read the “wdtv.bin” file with the ORIGINAL firmware information and overwrite the update with the original firmware that came with WD TV.)

  1. Place the two files"wdtv.bin" and “wdtv.ver” (new version 1.03.02) into the root directory of the USB drive

  2. Attach the USB drive to the WD TV and do a firmware update using the “Settings” menu

(The WD TV will update - DON"T do anything else until the WD TV has updated and rebooted.  You should come back to the original start screen)

  1. Attach your USB Dual-Drive Enclosure and turn the enclosure on

10)  You should see USB 1 or USB 2 depending upon which USB plug you used on the WD TV

(When you click on the USB 1 or USB 2 icon, both physical drives should show on your screen)

I apologize to all the Geekheads who found this very boring and too wordy.  My purpose was to try to explain the instructions to those who have a novice understanding of computer technology.

Thanks again to JudyP and WD Forum Ninja for their work!!