Bad controller or HD (3.0TB SATA WD30EFRX)

Any best practices for testing the controller? Can hear the HD spin up but drive access is sporadic at best. swapped cables, link lights are green and on, front LED comes on after (unplug) reboot, stays lit, blinks then stays out

Just need to pull off files

What color is the front LED? What does “drive access is sporadic at best” mean? Can you access the My Cloud Dashboard? What program or app is having sporadic access to the My Cloud? Is network router issuing an IP address to the My Cloud?

One can remove the hard drive from the My Cloud enclosure and attach it to a computer running Linux or running a Linux driver to read the My Cloud hard drive Linux formatted partitions.

LED is (steady) yellow (right now). If I unplug and plug back in enough times I’ll get a connection and can pull off 2-3 files (most of the drive are large videos or RAW files… No access via UI - sometimes it’ll connect but never makes it though initialization. Yes I can see an assigned MAC and IP.

Just need a way to pull off the remaining files - I have a new MyCloud Home

The My Cloud and My Cloud Home are different devices/products. You should see the dedicated subforum for the My Cloud Home where people more familiar with that device may be able to assist and where you can search (magnifying glass icon upper right) for past discussions similar to your issue. Note that the post link I included before discusses what to do on a My Cloud product and may not work for the My Cloud Home.

@Bennor ?? Yes, I know - I purchased the “home” version as a replacement. The MyCloud is the one having issues.

Oh it wasn’t clear by your post that the Home was a replacement drive. To get at the files on the single bay My Cloud hard drive, shuck the drive from the enclosure (see various Youtube videos on the subject) and attach the drive to a PC using a SATA to USB adapter/docking station or use a spare SATA port on a desktop PC. Then use Linux or if using Windows a Linux driver to access the contents of the hard drive where you can copy the files off the drive to the new My Cloud Home drive.

If you have trouble accessing the hard drive using Linux then that may point to problems with either the drive or with a firmware upgrade that some have experienced with the recent v2.x single bay My Cloud firmware upgrade causing the unit to fail to boot and get stuck with a flashing blue front LED.

If you have a spare SATA drive you could test out the My Cloud motherboard by “unbricking” the drive using one of the various unbrick methods and see if the spare drive works properly on the My Cloud motherboard…

1 Like

OK, picked up the inateck SATA to USB adapter; can anyone recommend the best Windows 10 Linux driver? Googled but the ones showing up have horror stories attached! (Like messing up the partition on the Windows drive)

See the previous link posted if you haven’t already…

One suggestion. Disconnect any other drives if possible. One further suggestion is to not bother with Windows 10 and disconnect all drives but the My Cloud drive and run a Linux boot disk/live cd disk. That way one doesn’t take the risk of inadvertently accessing the Windows drive(s).

@Bennor if I disconnect, how and or where do I put the files from the MyCloud (Linux) drive? Way too big for USB or DVD.

Would an external FAT32 or NTFS dive be accessible?

A Linux boot disc will mount almost any drive attached. Or one could access their local network (assuming network hardware supported) to copy the files elsewhere.

The point being if one is worried about corrupting their main Windows OS drive one can disconnect it and use another storage device.

1 Like

I had an (older) laptop which I used, created a bootable USB drive with Ubuntu and got it up and running.

I know nothing about Linux (started out on DOS so I know command line commands)

I plugged in the MyCloud drive, opened files but do not see the drive listed and if I click “Other Locations” I only see Computer under On this Computer and MyCloud-xxxxx & dp-723509B2 listed under Networks.

If I go to apps and “Disks” I can see the 3.0TB drivewhich appears to have 9 partitions ranging in size from 1MB to 3.0TB including a 513MB swap.

If I click on the 3.0TB partition and try to mount it I get an error: Error mounting /dev/sdb4 at /media/ubuntu/(long string): wrong fs type, bad option, bad super block on /dev/sdb4, missing codepage or helper program or other error (udisks-error-quark, 0)

What am I screwing up?

(edit: accessing the 3.0TB (WD30EFRX) drive via USB to SATA adapter)

Did you have the My Cloud drive attached to the laptop when you booted the laptop using Linux?

Does the USB to SATA adapter have it’s own power supply? In other words an adapter designed for 3.5 inch desktop style hard drives. Using a unpowered 2.5 inch laptop adapter may not provide enough power via the laptop’s USB port to power a desktop drive.

From my experience (if I remember right) using Linux and a My Cloud hard drive, Linux would mount the drive and partitions automatically.

Yes the USB to SATA adaper is powered and I tried booting both ways.

Never used Linux so maybe I’m missing something?

Should’t I be able to do a dir (directory) of all the files on the drive?

Only if the partitions are listed in the /etc/fstab file.

If you are booting into Linux. Then you can run fdisk to get a list of disks that Linux knows about. You can also use the mount -t ext4 /dev/sdXX /mnt to mount the partition. If it mounts then you can cd /mnt then ls to get a list of files.
You should also be able to attach a USB drive and mount it. Then you can use a cp -r command to copy files from one partition to another partition. The -r is recursive meaning copy all file in this directory and sub directories.

Generally yes but (again going from memory that may not be correct) when using a live boot cd/flash drive like Ubuntu I thought it would scan for drives during the boot process and list found drives/devices in the GUI.

Even if it doesn’t one should still be able to mount the My Cloud partitions so they are viewable in the Ubuntu GUI’s file manager program. If one is having trouble mounting the drive then it’s possible (a guess) the drive or it’s partitions could be corrupted.

Edit to add: Quick test. Plugging in a 1TB WD Blue USB hard drive into a laptop running Ubuntu Live CD shows the drive on the desktop.

Another example this time booting with the USB drive attached, it shows up in the Ubuntu file manger as unmounted but will mount (and show on the desktop like previous screen capture) when opened.

@rac8006 - here is a screen shot of what fdisk -l is showing (again I’ve never worked in Linux so I’m not sure how to interpret the file system.

There is one additional piece I’ll add in; there were multiple shares on the drive (7-9 I think), at one time. I started clearing off files and deleting shares and I think all but 3-4 were empty when the fail happened

(edit: the drive in question is the 3.0TB at the bottom.)

You could try an lsblk -f command. The /dev/sdc4 partition should be ext4. If you run lsblk -f
hopefully t will show that the partitions is ext4. If it is you should be able to do the mount command.

Here is the output from my Cloud gen1.