Backup won't start

I cannot get my back-up to start either. I have set up the date and time, hit go, and it says preparing to back up. I even got it once to say back-up completed, but nothing was actually backed up, except for a user directory. The actual files ARE selected, but the program won’t pull the files in.

I am having the same issue. WD Backup seems to install correctly (Windows 10), update itself (v. 1.9.6485.41936) and give me the set backup schedule window. I leave it at the hourly default, hit “Backup Now” and nothing happens. No progress bar, and the window tells me that “Last Backup” is “None”. I’ve left the drive hooked up and the computer running, but even the supposedly hourly backup isn’t happening. Help from actual WD support team members would be appreciated. TYIA

P.S. I have also tried uninstalling and reinstalling WD Backup. No change.

Same here, preparing backup forever 4tb my passport with only looking to backup lightroom catalog… any ideas after reinstalling software?

Simply wish the darn backup software would even load. I have an old 500G drive with the older tools and it works flawlessly. Frankly I hate the new tools and may end up returning the darn drive as this is was too much a pain to just get a good backup. Looking at all the posts above, seems everyone is having the exact same issue. What up?

I have the exact same problem
Have tried everything that was recommended here but no result

OMG…I am so upset…this WD DRIVE is USELESS…not even backing up with schedule now OR “backup now” …I loved my seagate…and am so sorry we bought this WD…no more ever again. NOT working at all…I have wasted my whole day TRYING to research this and NO one seems to have any clear cut answers…how could a big company not support something as simple as a backup drive? I am now going on my social media to let my 1000+ friends KNOW not to ever buy one…I’ve had it.!!!