BACKUP FAILED using time machine! "sparsebundle already in use, please disconnect . . ."


At random times, time machine fails to back up. The error I get is something about the sparsbundle is in use, and I need to eject it. Problem is, there is nothing to eject. I see the mycloud when I open a finder window on the left hand side under the heading “shared,” but when I have over it, there is no eject option (I also checked the tool bar, and there is nothing either).

An example of a typical failure:

My computer will be on, “time machine” will do several successful backups within a few hour period, then one will fail. This is without me touching anything.

After googling, it appears this problem has plagued people for years, but I still cannot find an easy solution.

My system:

WD Mycloud mirror, Raid 1, 6TB.

Macbook pro, OSX Mavericks 10.9.5. 2.9 GHz Intel Core i7

All software on computer is up to date, all firmware and software for the mycloud device is up to date. 

What I have tried, nothing fixed the problem:

(1) I’ve renamed my computer and the timemachin backup file without any apostrophes (I found this advice in WD’s website)

(2) I’ve shutdown my mac, with various times frames before starting it back up again.

(3) I reset my router.

(4) Disconnected and logged in as “guest,” and as a “registered user” in the finder window and tried to start time machine (I did this by opening a finder window, then clicked on “mycloud” text under the “shared” section on the left hand side, then once the window opens, there is a “connect as” button on the top right hand side of the window. 

(5) same facts as # 4, except after I logged in as “guest” or “Registered user,” I logged off and tried to start time machine. 

One possible solution

There is one thing that has worked, which could be a coincidence or an actual solution. I did this once, so I’m not sure if the first thing would work by itself (I know the second does not work by itself).

(1) I logged into the wd dashboard, and I rebooted the wd mycloud.

(2) then, at the same time, I restarted my computer.

Please help if you know. I’m not to mac savvy, so its appreciated if you use laymans terms. 



I recommend you contact support directly for assistance with this issue.

Contact WD

Yeah, I would, but this is posted on WD’s website, and I don’t want to call apple because they will charge me.

"Note: WD does not provide technical support for Time Machine related issues. For assistance with backing up to a WD NAS drive, using the Time Machine application please contact Apple. As the backup application is built into the OS, they are the only ones qualified to diagnose a Time Machine related issue.

If Apple is unable to assist with the issue at hand, the only additional option we can offer is to replace the drive. For assistance replacing a drive please see Answer ID 8: How can I replace a product under warranty?."

I expect more from Western Digital, if they expect people to buy and use their product, they should ensure issues like this don’t ocme up, or have some solution when they do. 

Just an update, I followed this post and my unit seems to work. I posted the information on what I did.