Backup Configure Error: Invalid Byte Encoding

I previously had a daily backup set when I originally plugged in my Passport for the first time. That backup was working properly and I had no problems from June until this week when I tried to open up the WD Backup program to make sure that the Passport was still backing up when plugged in…

It doesn’t open the view I am used to, but does give me options so I figured I could just configure a new backup to the Passport and it’d be fine… nope. The error when I click to proceed is that the Passport has “Invalid Byte Encoding”.

ANY suggestions on things to try or someone who has walked through this before??

I can access the files on the Passport and transfer files to it still, but I would like to be able to backup my entire computer once a month at least.


I haven’t seen this case before. Have you tried installing the backup software again?

If stills the same after installing the software again, please contact WD Support for further assistance.

Has this been resolved?
I have the same problem