AVCHD .mts Is there a fix

First I bought the WDTV Live and played my .mts files perfectly but I updated the firmware.  I know bad decision so I went back to the original firmware.  But I wasn’t liking having to hook up a hard drive so I got the live hub.  I have the issue with when I play a .mts file, it plays 5sec -video freezes - audio starts 5 secs then both video and audio play together.  So are the devices different or is the firmware’s need to be tweaked.  Also when I hit play on the Stream Folder it plays fine but doesn’t seem to play all the files in the folder

It’s a bug in the firmware that needs to be fixed.  I have over a terabyte of home video in .mts thats hard to watch because of this bug.  I put a Live in every room because it played my .mts files with 1.02.21, even though it’d take a good 10 seconds to start.  My freeze is more like 15-20 seconds before audio and video syncs.  I really wish someone would let us know if this fix is in the pipeline.  Any insight mods?

1 Like

Yeah hopefully WD will hear the cry’s for help. This should be huge topic soon with all the AVCHD Cameras coming out now.

I have reported the same problem couple weeks ago, but still without response. It’s realy pitty, because it worked fine in previous versions. Please help!!! 

The video streaming issue may not be the fault of the WDTV Live box. There are reported cases that the primary cause is the Windows 7 networking. I had a number of issues with the Windows 7 networking and buggy DLNA server software. I can now stream an m2ts video stream from an emachines N450 notepad using Windows XP SP3 Home to the WDTV Live box using Serviio 0.52 over cat 6 with no stuttering issues. (Serviio 0.50 was buggy; it gave me problems) Test bluray m2ts Pirates of the Caribbean 3. I would suggest trying the WDTV Live box on a different computer using a crossover cable and check the network setup. The maximum CPU use on the N450 is 60% with a maximum of 40% on the inbuilt 100mbps network chip.

I have exactly the same problem. I have tested four different network configurations (DLNA and Networkshare).

with two different NAS, one from WD and a ReadyNAS NVX, and two different gigabit switches Netgear GS 108 and TP-Link.

The behaviour is always the same. Video plays for around 5 seconds - video freezes - audio starts …

With another Mediaplayer (BluRay with Mediaplayer functions) the videos play without problems.

This issue has been fixed in the latest firmware in testing.

1 Like


It’s not a bandwidth issue, it’s an audio video sync bug for the first 30 or so seconds.   My files are home videos from a Sony camcorder which are AVCHD in .MTS.  If I rollback firmware to say 1.02.21, the problem goes away, so of course it’s the fault of the Live’s current firmware.   All 3 of my Lives have the same issue whether it’s directly connected, wired gigabit, or wireless N…just as everybody else reporting it.  

…but it’s awesome to officially hear that it is being fixed.

Thanks for the heads up Guy_K.

still dosent work with the Release 1.04.22 (3/8/2011) i have tested it yesterday. Please go on working on it  to fix it.


emmess12 wrote:

still dosent work with the Release 1.04.22 (3/8/2011) i have tested it yesterday. Please go on working on it  to fix it.



As has been said a couple of days ago they have fixed it and no doubt it will be in the next released firmware.


Is there any improvement on the time that it takes for an .mts to play from when you hit the play button?  I remember in 1.02.21 it took at least 15 seconds to start whether streaming or attached USB.

Hi guys

I’ve got the latest update, but still got this issue of 5 seconds without audio, then the video freezes untill the audio is at the point where the video stopped.

When I reported it to the original WD service, their answer was to resync the video. I already told them that that’s is not a solution. When will this bug be fixed?



Read post #7


much better now with  Release 1.04.31 (4/6/2011) but still not perfekt. Keep working on it!


Problem solved! For me it’s perfect now. Thanks WD guys!!!