Audio issues with movies and audio files


at first: Sorry for my english, it’s not my native language.

Now my problem: I bought the wd tv live hd a few months ago (with firmware 1.03.xx). There were a few dropouts in every mp3-audio file i played. So i was happy when the firmware update came (1.04.10 i guess). But instead the problem was fixed, it grew up and the count of dropouts grew up. So i went back to the prev. firmware.

Until that point i used the wd tv live hd only for playing audio files (mp3).

In the meantime i also tried to play some video files (avi-container with xvid-encoded video and mp3-encoded audio). But there is no fun to look this videos, because there are many audio dropouts. The video itself is looking well. The dropouts are at least every 30 seconds, sometimes every 5 to 10 seconds.

So i tried the newest firmware update (1.04.17). There is no change: Video itself good, audiotrack in video with many dropouts and audio in seperate mp3-files with some dropouts.

BTW: I played all files from a local connected USB WD-Elements HDD. So there is no network influence. Video is connected via HDMI and sound is via the digital output.

Every 20 Euro can play my mp3s whithout any problems. Why is this WD not able to produce a sound without dropouts?



I made an update to the latest firmware today and found that I have lost audio in .avi and .mov files.

There were sound though in mp4 and wmv files.

My setting was after update HDMI auto. In my Sony Bravia 3 TV it will not work.

When I change to 1080i 50 Hz (Sweden) I got sound back in my videos.

Check your HDMI setting and change to the setting your TV can manage.



thx for your hint.

My TV (Panasonic TH42PX8EA) plays 720p, 1080i (50/60) and 1080p (24/50/60). I tried all possible values on the WD Live.  No improvement.



i’ll buy a media player from another company. Perhapbs that can do such difficult things like playing a mp3-file or view an avi-file without dropouts.

No i am getting closer to the problem. All movies that doesn’t work have ac3 sound. avi with mp3 sound working ok.


You are using the OPTICAL output? To what is it connected?

I’ve partially lost audio in the latest 1.04.22_V firmware too…

.avi files with mp3 audio do not work (picture but no sound)
.mkv files with DTS audio work fine

Not got any other media types to try. All worked fine with 1.04.17_V

WDTV Live to Sherwood 5.1 amp, via TOSLINK, playing files served from Twonky Media on a QNAP TS-219P+

After a bit more trial and error, here’s a some additional detail:

  • mp3 audio - does not work via optical, but does work via HDMI
  • Dolby/DTS Digital audio - the reverse happens (does work via optical, but does not work via HDMI)

So my workaround until the next firmware update is to listen to mp3 audio (incl video files with audio encoded as mp3) via my TV’s speakers. Far from ideal.

When I bought the WDTV, I did expect it to be something I could leave by the telly, connect to the network and let the family use. However, it is far too techie and problematic for non-geeks to use imho.