At first I was like; but then I was like


#1

I was so excited to get the WDTV Live for Christmas. I actually dropped hints to the gf for a product I actually wanted instead of being indifferent like I usually am that time of year. It was just the thing I needed! Then I plugged it in.

I wanted to write a complaint to WD customer relations but of course I can’t find a link to do that anywhere on the website. I guess I’ll complain on the forums - got nothing else to do.

This thing has been flaky since day 1. Every time new firmware was released (which used to be frequent), I’d be hopeful “maybe this will fix things!” Nope!

I went out and bought a new wireless-n adapter since mine wasn’t on the terribly short Approved Hardware list. $70 or so. Spent 30 minutes one night trying to type in my 63-character network password; trying to use the dinky remote and the onscreen keyboard I could barely read; then typing it again, only this time the previous characters were masked. On my projection TV / looks like l looks like \ looks like !, and , looks a lot like … Eventually I was able to get on the network.

I kept having problems so I came here and someone mentioned doing a power cycle. I did it and lost the network key. So I changed my password to something less secure but easier to type so I didn’t have to go through that bullsh** again.

Kept having problems so I reverted my router firmware from DDWRT back to stock (thinking that with such a small supported hardware list I dare not change anything). No help.

I even went so far to buy a new router, making sure it was on the approved hardware list, to take advantage of 5GHz band and hopefully get this little box to work like I hoped it would. No.

Now I’m stuck with a media player that experiences most of the blips and headaches mentioned over and over again on these forums. (The funny thing is, some people just plug it in and everything works weeeee!). I don’t know what the problem is but I changed everything around to make my network look as default as possible. Maybe I got a bum unit but gee there sure are a lot of similar complaints.

With the money I spent to try to get everything working smoothly, I could have bought an Acer Revo or something.

I still play videos and music through the WDTV Live when it sees my network shares. I’ve worked out a button-press series I can do when my videos freeze, and it works about 80% of the time so that’s good.

I suspect this product was rushed to market. I don’t understand why there should be such a short list of hardware that works with this product; or why there are so numerous of problems. The price of this product is not worth all the frustration and headaches. And it ■■■■■ because I was really excited when I heard about it! I am seriously let down with the performance and the un-polished user interface of this device, and the remote, the _ only _ input, feels so cheap I doubt it will hold up for too long. I have had good experiences with WD products in the past but this really is a severe letdown. I do not recommend the WDTV Live to anyone and in fact I tell friends to avoid it.

Hope this helps!


#2

“Hope this helps”…

How was it supposed to help?

Have tried hard wiring the unit with an Ethernet Cable?


#3

Due to my floor plan a wired connection is not possible.

Hope that helps!


#4

 I know this sounds nuts, but if you have a newly formated USB device (either hard drive or USB stick) and you throw a movie or two on it, and plug it right into the WD Live, do you have the same issues? I am just asking because it seems that most of the lockups and Death Wheels I see people talking about are related to people trying to access their NAS or other network shares.

 This is by no means a “fix”, I am just curious and was wondering if you would be up to test it out?