[APP] Transmission various versions for firmware V4+ (04/2018)


#741

The v2.x My Cloud is a newer device with supposedly newer hardware. Think generation 2 versus the generation 1 My Cloud’s that use the v4.x firmware.


#743

Wow, thats confusing :slightly_smiling:
But still, can I install transmission on it?


#744

For v3 firmware you can easily install from Jessie repo. I believe there’s lots of guide for v3 in the past. But I strongly recommend to upgrade to v4 for security and especially performance (speed) improvements. For your case since you can pull out the hdd for manual recovery, try dumping the latest v4 firmware rootfs.img extracted the latest http://download.wdc.com/nas/sq-040402-105-20160111.zip.


#745

Bennor is correct, on top of that gen2 it’s a bit faster than gen1 especially the 512mb ram means lesser swap trashing. Think it now the software belongs to the same family as mirror/ex/dl series except for still armhf, when first launched I saw the source code containing busybox instead of debian :frowning: You can still install transmission on the gen2 but not with this installer as I don’t have the time and device to support it, see Fox_exe’s jail method https://community.wd.com/t/wd-mycloud-gen2-chroot-transmission-and-minidlna/ which according to him you will need to launch it manually every reboot.


#746

I noticed that the problem occurred when I was trying to download some Linux distro. Not sure if it was problem of this particular torrent - on PC is was downloading at full speed up to 25MB/s. On WD it instantly froze the device.

Anyway, I tested on some other torrents, and managed to get some decent speeds - but ultimately I set DL limit in Transmission to 5MB/s, and now seems stable.

I am also thinking to switch to NZBGet, which runs quite well on WD My Cloud.

Thanks Nazar78 for all the work you are doing - I am using your installers and they work great!


#747

You can imagine the speed I’m getting on my 1Gbps fiber downloading off the wired PC/Laptop :stuck_out_tongue: We do have 2Gbps here but that’s overkilled unless I switch to link aggregation.

Where else on the MyCloud it’s only around 10MB/s +/- but it’s good enough for me for casual downloads and scheduling my fav shows once a day via FlexGet cronjob. My settings are simple, the rest are almost default. Below are the ones most particular:

  1. Enabled download queue, max queue = 1, also set a low max seed queue if you’re super-seeding.
  2. Max global upload speed = 1/4 of my upload bandwidth, download full.
  3. Maximum global number of peers = 200
  4. Maximum peers number of torrent = 50

A rule of thumb, don’t go berserk on the settings, set good low value or the NAS will freeze.


#748

What happened with your web site? When I try to put captcha code, I’m redirecting to some warning message about advert blocking.



#749

Which browser? Go to its plugins or addons settings and temporarily disable any adblocker. It could also be your AV blocking adverts. Just whitelist, suspend or disable them temporarily.


#750

I tried different browsers on different machines. Same result for all cases. I don’t have any adblocker software.


#751

Do you have any AV (Antivirus) active?

Try browsing in incognito or inprivate mode. Usually addons will be off in these mode unless setup otherwise. E.g. in Chrome CTRL+SHIFT+N.


#752

Thanks man! That works for Chrome.


#753

NP… Enjoy (-:


#754

Ok, thanks Nazar78 for the hints. Actually now I am testing some other solution: I installed OpenVPN and using PrivateInternetAccess while downloading torrents. Max speed with OpenVPN enabled in Transmission is around 2MB/s, which may seem quite slow… But looking at CPU and memory usage - OpenVPN is consuming quite lot of NAS power, so I guess this would explain lower speeds. But anyway, I prefer using torrents only with VPN enabled.

In long term - I think I will switch to Usenet for my tv shows, rather than torrents. I tested your NZBGet with Sickrage - all works great, downloads at very good speed (10MB/s), with SSL connection enabled, so no need to use VPN in this case. And no freezes of NAS.

Only thing is USENET (incl. VPN) will be around twice more expensive than VPN from PrivateInternetAccess I was using up till now. But I guess I will have to live with that :slightly_smiling:


#755

Hi Nazar78! Are you planning to update Transmission to the current version 2.90 that was released today?


#756

You bet on it, hang on tight!


#757

For those who’s following this post, a new version has been added to the first post. If you have installed the earlier version, you can just install over this newer version. As promised to my donors, they will be the first to receive newer builds. I’ll make it public soon so stay tuned (-:

[20160301] Added Transmission v2.90-1.

#758

Good morning Nazar, to upgrade to the latest version you just put (2.90) having already installed on my Cloud’s 2.84, as would have to upgrade, following the normal steps as if a new installation or need to create backups ?

Thank you very much for your great work.


#759

If you had installed v2.84 from my installer, just install v2.90 normally. All the settings will be preserved. The backups are only needed if you do firmware upgrades and would like to retain the Transmission settings.


#760

thank you very much for your answer.


#761

Hi Nazar.
Im getting this error with this last version.
2016-03-02 16:55:37 SEARCHQUEUE-MANUAL-281485 :: Transmission: Unable to send Torrent
2016-03-02 16:49:15 CHECKVERSION :: No git specified, can’t use git commands
2016-03-02 16:32:56 SEARCHQUEUE-DAILY-SEARCH :: Transmission: Unable to send Torrent
2016-03-02 15:55:16 SEARCHQUEUE-BACKLOG-281485 :: Transmission: Unable to send Torrent

Torrents aren’t being sent to transmission