[APP] Transmission various versions for firmware V4+ (03/2019)


#21

With normal download on PC, i can download with about 15 MB/s

Transmission only works at about 5 :frowning:


#22

I’m on 300mbps fiber but getting only average 10MB/s. Can’t expect that much from a dual-core arm cortex-A9 650 mhz cpu with 256MB ram.

Heavy duty torrent jobs I leave it to i7 while at home. While away from home, Transmission comes in handy when mobile torrenting struggles with LTE.

You could try play around with the max peers connection settings, see if it helps…


#23

Nazar78

Please need help startup tranmision at boot not working,

REGARDS


#24

Just in case, are you able to run transmission-daemon from the command line to ensure its installed correctly?

Did you install the crontabs below?

crontab -l>.crontab;echo @reboot transmission-daemon>>.crontab;crontab<.crontab;rm -f .crontab;

My method uses cronjobs to start it at boot. Check your crontab enter ‘crontab -l’ see if you can find this line “@reboot transmission-daemon”.


#25

Thanx for reply,

with

transmission-daemon command line tranmission working fine & also installed crontabs but steel auto start after boot not working.REGARDS

#26

Check your crontab again, run “crontab -e”. Ensure there’s no typo or extra spaces “@reboot transmission-daemon” (no quotes). Then ctrl-x to save within nano editor.


#27

PLEASE HELP!

I have the same problem - transmission does not want to run automaticly on start after reboot or power on.

My method uses cronjobs to start it at boot. Check your crontab enter ‘crontab -l’ see if you can find this line “@reboot transmission-daemon”.

I tried this method but it did not help me solve the problem.


#28

Run crontab -l

Paste the results or screenshot here.


#29

it’s seems like cron don’t wants execute this command after reboot or cron doesn’t start automatically on device boot. i don’t know where is the problem :frowning: Please heeeelp!!!


#30

Ok lets find out why, run below and return us the results. Just copy paste from putty to here. Screenshot posted will take some time to be approved by mods.

ps -ef | grep -E 'transmission|cron'

#31

Hello,

Did you guys notice any difference on the system’s performance? I would like to install it but I dont wanna risk the performance and the reliability of the system.

And what about the standby mode? If the daemon is running 24/7 it doesnt means that it will not allow the disk to get into the standby mode?

Thanks


#32

Of course when there’s torrenting activities, the rest of the file transfer activities load will be shared. You could choose to let the daemon runs 24/7 or stop it after you’re done. Either way, if there’s no downloading or seeding, the disk will spin down after 10mins of no activities. You can review the /var/log/user.log to confirm standby mode.


#33
ps -ef | grep -E 'transmission|cron'

Using username “root”.
root@192.168.1.121’s password:
Send automatic password
Linux WDMyCloud 3.2.26 #1 SMP Tue Jun 17 15:53:22 PDT 2014 wd-2.2-rel armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri Sep 5 12:51:07 2014 from 192.168.1.102
WDMyCloud:~# ps -ef | grep -E ‘transmission|cron’
root 7450 1 0 Sep04 ? 00:00:01 /usr/sbin/cron
root 8015 1 0 Sep04 ? 00:01:55 transmission-daemon
root 17826 17817 0 12:51 pts/0 00:00:00 grep -E transmission|cron


#34

@shefalick, both cron and transmission seems to be running. Try reboot mycloud and run that command again see if you get the same results.


#35

After reboot and retyping command:

ps -ef | grep -E ‘transmission|cron’

it  shows me that:

Using username “root”.
root@192.168.1.121’s password:
Send automatic password
Linux WDMyCloud 3.2.26 #1 SMP Tue Jun 17 15:53:22 PDT 2014 wd-2.2-rel armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri Sep 5 13:12:42 2014 from 192.168.1.102
WDMyCloud:~# ps -ef | grep -E ‘transmission|cron’
root 7451 1 0 13:16 ? 00:00:00 /usr/sbin/cron
root 7954 7945 0 13:16 pts/0 00:00:00 grep -E transmission|cron


#36

Ok I think I see the issue now, the root environment doesn’t see the executable path when cron runs. Edit your crontab again “crontab -e”, change to below. Reboot see if it works.

@reboot /usr/local/bin/transmission-daemon

#37

Cool!   It’s working now!  Thanx alot!!!


#38

I hope someone here knows more then I do about this situation. I installed Sickbeard on the nas to work with my transmission client. My problem is that files created and moved around by apps running as root on the nas arnt maintaining proper ownership. In transmission-daemon/setting.json I have tried changing the Umask between default 18, and setting 0,  or 2… they all apear to only change the downloaded contents permissions. currently ok I have everything set to 770. When a torrent starts it is a .part file in /DataVolume/shares/user/Incomplete-Downloads that folder is owned by user and group is share. The files created by transmission in the directory are owned by root with group set to share. So far not and issue. When the download finishs its moved to /DataVolume/shares/user/Downloads where it also maintains root:share ownership. Sickbeard post procceses tv shows be looking in the Downloads folder and moving finished shows to /DataVolume/shares/user/Downloads/Shows and into there respective sub-folder. The problem is that Sickbeard changes the ownership and group to of some files. This is usually just the text files and images. However now I can’t open the images or srt files via smb due to lack of permissions.

Do any of you know a hard fast way to maintain all content in a folder as a specific user:group without having to log in via ssh all the time to 'chown -R user:group ’ my folders.

PS when I enter the Shows folder and ‘ls -al’ even the parent and current folder are owned by the proper user:group


#39

@nate9000, I’m not sure about Sickbeard, if it even supports post/pre commands. Why not just chmod 777 the folder Downloads/Shows? You can also add a cronjob “crontab -e” to seek and change the permissions on interval basis.

E.g. below is to run every minute to perform chown on files/folders changed less than 1 minute.

* * * * * find /DataVolume/shares/user/Downloads/Shows -cmin -1 -exec chown user:group {} \; >/dev/null 2>&1

E.g. below is to run every 5 minutes to perform chown on files/folders changed less than 5 minutes.

*/5 * * * * find /DataVolume/shares/user/Downloads/Shows -cmin -5 -exec chown user:group {} \; >/dev/null 2>&1

#40

The cron job is a good idea I will have to implement that if I don’t have this fixed. Its so weird everything works great just .nfo and .jpg type non executable files are created under the wrong group. I might have forgot to chmod g+s one of the folders these files pass though. I’m testing it right now to see if SickRage puts the newly downloaded files into the folder with group access. I would chmod 777 but its not a public share and dosn’t need to be.