Anyone having trouble with 2 My Book essential hard drives at once?

It only happens when I plug in 2 usb 3.0 3 tb hard drives to my computer. one reads, the other kind of doesn’t. I can see the other one in safely remove but it never loads, unless i plug out the one that did read and reconnect the one that didnt read and vice versa. I installed the ses drivers but it didn’t help. Im trying to move data between and so far the only way i can is by copying to desktop’s internal hdd then switch externals and moving to external, which is time consuming not to mention leaving a lot of file defragmentation on my desktop’s internal hard drive. Any one have a clue? this only happens for 2 usb 3.0 ones. I own 2 usb 2.0 ones and they read  fine with each other. And its not the usb 3.0 ports on my computer because I also tried it for usb 2.0 slots and same result. I even tried mixing, one on 3.0 and other on 2.0. still nothing. plz help if you can.

edit. I forgot to add. This might be irrevelent but I like to designate a letter for each hard drive for easier access and shortcuts and whatnot. The weird part is both of these hard drives, when one is being read, seems to use the same letter. Like when i plug in #1, its set to M. Then I plug it out and plug in #2 and it’s also set to M. Maybe this is helpful to finding out the issue. I’m not sure.

Try changing the letter on the second one and make sure it’s online.


I did that already. I changed the other one to T. Then when i replugged the previous one in, it also read as T.