Another vote against the updated firmware ver. 2.10.302

This firmware has turned a well working device into a slow , ungainly and frustrating mess. 

I already read the list of “fixes” I don’t have any apps installed, don’t have itunes etc. 

now I am getting complaints from my users that it is making it slow to open any files stored on it etc. 

Can this update be reversed or can we expect something that actually works soon? 

It also seems to have cancelled my Elephantdrive backups. 


On top of that the system is so slow and bogged down that I can’t even submit a support request/ticket. 

What next? 


Hi, there have been some users on the forums that have being able to rollback the firmware, however WD does not support this.

The drive may seem slow as it needs to recreate the data base for all the files that you have on the unit. When did you upgraded the firmware?

I think it auto-updated about a week ago while I was out of the office on vacation. 

I got back and the UI was changed etc… exact date unknown. 

After a reboot it reported that the power supply #1 was bad and i have tried submitting a support ticket for that but when i try and generate a system log i get a time out. 

Will keep trying. 


Hi, if you already have an interaction with WD, you should be able to save the log file and send it to them attached to an email.

I have tried savign a log file but it seems to time out before it can finish the operation. I also have 2-3 others working on files that are on the unit so I have to be cautious about what i am doing so it does not hang them up. 

I will try again later. 


I have the same problem. Thank you for stating that the UI changed. I went from black background to a solid white background. My problems happened in same time frame as the UI change.

Thank you! Now, I know I’m not nuts…

indeed- you are not alone. 

I had just enough time with the old interface that it got to where i was not logging in daily to check it…then *poof* it changed. 

Still can’t seem to get it to create a diagnostic report or system report to submit. 

It said it had a failed power supply #1 upon last reboot but i can’t seem to find and errors now. 


1 Like

I opened a support ticket…was told to do the 1st level of helpdesk stuff…basically, reboot and if that did not work, do a soft reset to factory defaults, I guess…not sure what the soft reset entails…however, in that process now [the soft reset because yanking power cord out only caused more delay and same error messages]…been at it about 30-45 minutes now.

BTW, I got error msg of power supply 1 failed initially because I seemed to have plugged into #2 port. Swapped power cord to #1 port and got same message about power supply failure on “2” the second time…weird, weird, weird…

It really irritates me that I have somewhere in the neighborhood of $1000 into this device, including HDDs, just to have some stinking update totally hose admin access and tools.

I have remained on v04.01.03-421  which while flawed has been stable enough I do not want to take any chances. Although I have reduced occurrances dramatically, just cant figure out why it wakes up so much even though I have everything disabled. I only want the thing to run when i using it…

I remember the old days when firmware updates made improvements and fixed issues. Now firmware updates reduce perfromance and create a mulitude of issues or render a device nearly useless. As far as updated  firmware and home NAS goes Seagate is just as bad if not worse then WD. Buffalo while a bit better it’s not enough to inspire confidence. Man I miss the old days.

Well it went and did it again- another update and now I am unable to log into the dashboard via web browser.

I can ping it via command line so it is there, and the shares are still active and read/writable?

What is going on with this?