Another My Book Essential 2 TB not recognized

My experience with a WD external HD is the same story I have read here many times, as well countless IT help forums around the web.

I purchased a My Book Essential in June 2011 to store personal files previously on my work PC - mostly photos and videos of my kids. I forgot about it until we began to upgrade our system two weeks ago. It was still in the box in a filing cabinet where i stuck it last June. It had plenty of room - so we were going to use it as a temporary home for files and preferences.

My PC did not recognize the drive. It showed up in device manager - but it could not be accessed. We tried it on several PCs and laptops. None could find it. We tried upgrading the firmware - nothing.  The IT dept tried accessing my stored files using recovery software - it ran all weekend and found nothing.

The photos and videos are gone, I guess. Not an easy thing to accept. So I began an RMA to have it replaced. Our firm wide upgrade is waiting on my having a functional external hard drive.

It was sent Priority Mail USPS Nov. 21 and delivered to WD in Riverside CA on Nov 24 - but this does not show up in the RMA status.

If anyone knows the answer to any of these questions - I would appreciate the input:

How do I find out if the drive been received? What is normal turnaround time? Does WD try to recover data or just toss the old drive?

Thank you -


I have passed your info for someone from our support department to contact you.

Thank you for your patience.

Thank you for your assistance - I received a private message on this matter.