Android / WD My Cloud - Cellular data transfer despite "wi-fi" only

I just wanted to let you know that my cell indicated 684 MB data transfer in the background over cellular network.

When I was configuring my app I made sure I selected WI-FI only, and this option is till this way (Auto Sync Wi-Fi only)

Please, fix the issue.


Welcome to the WD Community. 

I haven’t seen this case before on the community. 

What version of the app are you using? 

Try to disable and then enable that option again.

Dear RMorel:

Thanks for welcome.

This is the very lastest downloaded yesterday from Android’s app store - 4.1.2

I will try your suggestion.