An operation is already pending WD Elements

Hi, I have a WD Elements which was working really really well.
But last week, I guess I had removed it from the system(I use Linux Mint as my OS) while some files were still being transferred. Since then it’s not responding at all. Every time I insert it, I get the error as in the screenshot. I have been lucky a few times when I was able to mount it to a drive(after a long long time). Even then the transfer rate for files started at around 50KB/s and steadily decreased to ~2KB/s.
I tried inserting it on a Windows system(my friend’s as I only have Mint on my system), but I get an error stating there is some problem with the drive inserted and it doesn’t appear on the list of drives or on Device Manager. Plz tell me what I should do? I have attached the screenshot.

Hello, microlifecc,

Well, I would recommend you to connect the drive to the another operating system and then check whether it is it asking for the same error or not and just try to format the drive using another OS.

useful link to follow:-

Hi, thanks for the reply. I’m on Linux. Can you plz suggest me a post for Linux Mint.