An issue with the iOS app


I have an issue using the iOS My Cloud app, and hoped someone could help.

I have a My Cloud drive that I use for local access only, without any cloud features activated whatsoever. Correspondingly, the device has its “Remote Access” option (under “Cloud Access”) deactivated, in addition to be blocked for internet access at the router level.

When attempting to access the drive locally using the My Cloud app (by using the “Connect to local drive” feature), I am prompted for password, upon the entry of which I receive an error (500). Using the web access interface, I am able to login normally. Yet, after each such [failed] attempt (using the iOS app), the “Remote Access” option is being activated automatically; this is visible via the web interface.

The error itself is presumably caused by the device’s inability to go online (as it is blocked at a gateway level), while it is, for some strange reason, trying to.

Yet, what I don’t understand is why would the device even attempt to go online when accessed locally (“Connect to a local drive”) and consequently, why would the iOS app cause the “Remote Access” option to be activated on each such attempt?

I am running the latest firmware and iOS app versions.

Thanks in advance!

Is your iThing connected to your local network WiFi? Or is it trying to do all data connections via its mobile data network?

It sounds like the latter.


Thanks for your comment!

No, it is connected to the very same WiFi network as the My Cloud. For instance, accessing (the local IP address for the My Cloud) from within Safari works.

When selecting the “Connect to local drive” option, it is presumed that the access would be restricted to LAN. Further, had I attempted to reach the My Cloud device via the Cellular network and not WiFi – such an attempt would inherently fail. You see, under my configuration, the My Cloud device is barred from accessing the internet at a gateway level. Thus, an attempt to access it from WAN (as opposed to LAN) would fail completely, and would not have an opportunity to reach the device; to display a password prompt or cause an HTTP error 500; and let alone, to cause a change in the settings of the device, as I described in my post.

By the way, I am able to reproduce the said behavior with the iPad as well (not just the iPhone), which lacks Cellular connectivity. Last but not least, I have never even signed up for any WD My Cloud online account, so logically it follows that I would not have any option to reach the device from WAN either way.


You have marked this as solved. Have you solved it? If so, how?

If you haven’t, have you connected the devices with the MyCloud? Go to the Dashboard, and check the number of ‘Cloud Devices’. There should be at least two: one for your phone, one for your iPad.

I just tried to use the app to access my device from this tablet. It gave an error 906. The solution was to go to ‘manage devices’ remove the MyCloud from the list. As soon as I did this, it popped up again in the available devices list, and when i connected to it, it asked for by username and password, and connected. Now I have access again. I suspect it was a change of IP addresses in my local network that caused the network error.


My bad, I probably unknowingly checked the “Solution” checkbox. The issue is not yet resolved.

Using the web interface, I see 2 cloud devices, which indeed are my iPhone and my iPad. I could not, however, modify that list without first enabling cloud access (which I don’t want to have enabled).

I temporarily enabled cloud access, just so that I could modify the sad list. Yet, removing any entries appears to be of little effect. Still, after removing entries, disabling “Remote Access” and attempting to access the device via the iOS app over LAN, error 500 appears with the “Remote Access” option is being silently re-enabled (why?).

One interesting observation: once I disabled the cloud access feature (after having previously temporarily enabled it to remove cloud devices), I saw a very interesting message, which read:

“By turning off Cloud Service, you will not be able to use any of the WD software such as My Cloud, WD Photos mobile app and WD Sync. Are you sure you would like to proceed?”

Why is this? Why would using the iOS app be contingent on having the device enabled for cloud access, when the app is clearly able (and, in part, was designed; see the “Connect to local drive” within the app) to access the device over LAN?


You can ignore that message for local access. The Cloud Access option applies generally applies only to Cloud Access. I have Cloud Access disabled on my My CLoud and routinly access the My Cloud using the WD My Cloud Desktop program, and the WD My Cloud app for Android (on multiple devices).


Thanks for replying. For me, the web access works flawlessly. Yet the iOS apps do not.

Is there any dedicated channel of feedback for the developers of the iOS version, that you know of? Do the developers read these forums?


Just dug out and booted my iPad2.

Opened MyCloud app.
Cannot access device (as above, it’s been a long time since i’ve used the app, and my IP addresses have changed).
Manage devices/remove.
MyCloud immediately appeared in ‘available devices’.
Entered my password and was able to access.
Went to Dashboard and turned off cloud access.
Still able to access mycloud via app.
Manage devices/remove.
MyCloud immediately appeared in ‘available devices’.
Entered my password and was able to access.

Looks like you have a local network problem of some kind, or maybe the mycloud needs resetting.

I’m running iOS 8.0.2 on the iPad.

You’re right about local use of the MyCloud app turning remote access back on. Seems to be caused by connecting to a device. Once connected, it seems to allow the app local access without needing cloud access enabled.

That’s VERY naughty, IMHO. You can’t just silently override the administrator’s Dashboard settings, which have a bearing on security. There should be a warning that it needs to do it, and a request for permission.

Bang out of order, WD.

1 Like


Thanks for your time!

I am able to see the device in the “available devices”, the problem is the error that appears right after I enter the password. Would you be able to test whether you can successfully view the contents of the drive if you block its ability to access the internet at a gateway level?

Thanks again!

P.S. I just did a factory reset, the same behavior still.

I simply unplugged my ADSL line…

Connected devices were still able to access the device.
Manage devices/remove.
MyCloud immediately appeared in ‘available devices’.
Entered my password and got ‘invalid request: error 400’

Reconnected ADSL, waited for it to re-connect, tried password again and it connected with no problem.

Looks pretty certain that the Mycloud and/or app need internet access to make the initial association.

I also use FileBrowser for accessing MyCloud device on local network.

it is what it is… since OS3, I think… the auto turning on the Cloud access and automatically maps the ports on your router if you don’t have those specified on your router.

I think just blocking the ports or even redirecting them to a non-existent ip that are mapped for cloud access should do the trick which will give you local access but not external wan access.

As ive just demonstrated, it needs internet access to create the association.

Silently modifying security settingfs is disgraceful behaviour.

Support case submitted.

Can’t happen here, as UPNP is disabled precisely because of implementations like the one you’re describing. :slight_smile:

It appears so, yes. It’d be interesting to find out why the implementation is such (when it could and should have been avoided); this simply prevents me from using the iOS app, as I am not willing to let the drive go online even once.

I appreciate and value the time you’ve taken to help me on this!


Another interesting thing I just observed: despite having both remote access and automatic firmware updates disabled, I still see very frequent (every 5 minutes) DNS queries from the My Cloud drive, attempting to resolve the IP address for URL “”.

I have any actual connection attempts blocked at the gateway level. Still, does anyone have an idea why are these attempts even made when having cloud features disabled? Why would anyone have to resort to firewalling the device, when all they want is to stop it from communicating with anything beyond LAN?

In the attached screenshot you can see this taking place at pretty much constant, 5-minute intervals ( is the local IP address of the drive; the “OK” status pertains to the DNS resolution attempt only, not to any actual network access).