An error was encountered loading the page


#21

I’m not having any issues with Firefox or IE11. I’m using Windows 7. However, I will have our programmers look at this.

One other thing, can you clear your browser cache and see if you still have this issue?


#22

Cleared cache in Firefox, restarted browser, logged in. Same error. Since this happens on multiple systems and multiple browsers I would suspect that my WD account is corrupted in some way.


#23

Hi @OleJack,

I haven’t forgotten about you. Our programmers are still looking into this.


#24

The programmers think they fixed your login. Can you check it?


#25

Yes, that seems to have fixed the problem. Thanks!


#26

Excellent. Glad to hear it.


#27

so this error happens every time some one updates their phone number?

I did that this weekend and now I am getting same message for days now.

OP reported this in Aug 2015 …we are in 2017

can someone help please?


#28

Hey I’m having a issue with my address not working with the create RMA on the website also my HDD seems too have a really poor performance !!!

You can email me using this address

[removed for privacy]

I also did some digging around and discovered I can’t message you on WD because of the Trust Level


#29

@ELIJAH_BURNS

I will need more details, so I’ll private message you. That way you should be able to respond.


#30

Hi,

I’ve just experienced exactly the same issue as the previous posters. I tried to change my contact number in Account Information and now I’m getting the following error when trying to access the Account Information page:

An error was encountered displaying the most recent activities.

Is there still some fundamentally wrong going on here?

Hope you can help. Many thanks


#31

Hi Bill

Same issue here… I just updated my phone number and now I’m getting the error:
“An error was encountered displaying the most recent activities”

Could you get back to me through PM if possible?
My WD e-mail address is different from the forum one.


#32

Hello,

I have an exactly same problem trying to access the Account Information page after changing my phone number (it wasn’t set at all somehow).

Please, help!