All my files are suddenly missing


I really hope someone can help me here. I was trying to upload some files to the new Google Music Manager from my WD MyBook. About 50 songs in, my computer was lagging a bit while I was trying to complete some work and so I stopped the Music Manager. Then, a few minutes later, I tried to “Safely Remove Hardware” and stop my WD MyBook but it said “it cannot be stopped right now, try again later.” After waiting awhile, I had to shut my computer down and go. When I got back and plugged my WD MyBook into my laptop, all the files were gone.

Nothing is showing up. No files and it says I have 1.24TB of 1.36 TB free. Can someone please help me get this back??? All my music was stored on this.


What OS are you using? In Windows look in Disk Managr and see if the disk shows there and what it says.I don’t know about Macs.


i need the solution to this as well!!!

my usage dropped from 23% to 8% . More than 100 GB just gone missing!

I am running windows 7

I have the same issue. The drive connects perfectly fine, My computer shows the drive, disk management shows the drive, check disk comes back with no errors, but when I open the drive, it is empty.

When I check properties, it shows my 500GB of data present.

If you have this resoleved, please help.

I forgot to mention, the link “Problem Resolved” does not present a solution.


At least I am not the only one. How do a product that I brought brand new have so many problems. I shouldn’t have to partition or reformat this drive and more than likely it will still not work. I will not buy another WD product again.

I am also having the same issue I am on windows 7 ultimate 64 bit and my files are also not showing up on my external when it shows that 300 gigs of it are in use but the files do not show.

I am having this issue as well.  The files are still there.  Try to make a new folder inside the hard drive.  This will likely cause one of your old folders to appear.  You may have to do this over a nd over, but your files will eventually all come back.  I am not sure what the glitch is, but it happens every time you unplug your hard drive.  it has been annoying enough that I will never buy another WD Hard Drive.