After upgrade WDTV Live FW 2.02.32 replay DVD5 over network share: screens stuttering


After upgrade the firmware of my WDTV Live from version 1.16.13 to 2.02.32 it’s no longer possible to play DVD5. The screen is stuttering and with this new firmware the WD TV live is useless to me. I playback the DVD5 from a Windows 7 SP1 x64 network share. I had tried to reset factory settings, unplugged the power cord.

I had the same problem after upgrading from 1.16.13 to 2.01.86. I had reported this problem but in response of WD the just deleted my messages! It’s very sad that instead of solving the problem they deleted my post. Hopefully I get more lucky this time.


Mr.Ibix wrote: I had tried to reset factory settings, unplugged the power cord.

Have you tried …  Setup > Audio/Video Output > Video Output > HDMI > Auto > Auto > Match Video Framerate > On?

Yes I have tried that setting. Unfortunately it didn’t had any effect.

bummer …

well, the only other thing i can suggest is … “manually” setting the video output setting to match your DVD5  framerate


If it’s an NTSC DVD5 (29.970fps) … then select 720p60Hz or 1080p60Hz  (if it’s “Interlaced” select 1080i60Hz)

If it’s an PAL     DVD5 (25.000fps) … then select 720p50Hz or 1080p50Hz  (if it’s “Interlaced” select 1080i50Hz)

also, have you tried playing these DVD5 on a USB drive (attached to the WDTV) to see if you have the same problem ?

I have tried the different video output setting as suggested. Unfortunately it didn’t do the job.

When I put the DVD files on an external  USB drive the playback of the DVD is without any problems. So the problem only exists when I play the DVD over my LAN from the Windows 7 share. Please notice I use a wired network. I have tested the used cable into another device and I can copy with 100Mb steady big files.

If it plays OK direct from a USB drive and not over your network then that points to a network problem? I have no problem streaming DVD isos over my wireless network from my windows 7 PC and NAS so it can be done, its just finding where your problem lies, the evidence seems to suggest a network issue.

Indeed everything points to a network issue.

In my opium it’s causes by WD TV Live. As I mentioned before I can perform a stable copy over my network. Furthermore the problems occurs only when running FW 2.01.86 or 2.02.32.