After updating to My Cloud OS 5, I can't access the dashboard

Hi, new user in this forum here,

I updated my MyCloud EX2 Ultra to OS 5 this morning and after rebooting, I can’t access to the dashboard. Strangely, I can still access to the files through LAN, but in this same network, the dashboard is not accesible. I have tried the new name I gave to the server, the default one, I have tried to set it up again, I also did the 4 second reset as well as the 40 second one but I can’t access it. The terminal command “arp -a” shows that it is apparently connected to the network. Is there something that I am missing?

1 Like

@mariomartreq The dashboard of a My Cloud can be accessed a few different ways:

The following KBA will be useful


1 Like

The above answer does not help me. It is not accepting my username and/or password.
The only view I have of anything is the screen snip below


The only option I have on this screen is to change my password. I am unable to view any other details that I know I have setup and yet aren’t being accepted.
Is there a reset button so I can start again from the beginning?

@psicorps the screenshot that you posted is for My Cloud OS 3 and not My Cloud OS 5. My Cloud OS 3 has it’s own Community Section, but the following OS 3 KBA will help you reset the unit.

How to Reset a My Cloud Device

Answer ID 27402

Hi SDBrown, for some reason, and after a good amount of hours after updating/rebooting, I managed to access to the dashboard through one on of the methods I had already tried many times. Thanks anyway for your quick response.

Thanks for the update. Can you provide your My Cloud System logs via private message? I would like engineering to take a look.

1 Like

Hi SBrown, the system does not allow me to send messages to you, being the error log “Sorry, you cannot send a personal message to that user.”

Please can you tell me how did you access the dashboard. I have the same problem.

1 Like

Hi. Yesterday I made OS update on my WD My Cloud EX2 to My Cloud OS5 and there is no access to dashboard via browser. I made MyCloud reset and nothing can’t help. Please find some solution.

I have the exact same issue - its been 2 weeks since my upgrade to OS5 and my dashboard access remains broken. I can see the NAS on my network and access the files/shares, but navigating to the IP address for dashboard access gives me a 500 error with " is currently unable to handle this request." or “refused to connect.”.

@SBrown is there any known guidelines on resolving this? I cannot access any logs without the dashboard…

I should have read the community posts before upgrading. Rookie mistake…

I am having this exact problem. Has anyone found a solution?

I have upgraded my MYCloud EX2 Ultra from OS3 to OS5. However, after upgrade I could not access dashboard at http://mycloudex2ultra . I then reset my device by pressing the reset button for 4 seconds. The reset seemed to work ok. After typing again http:/mycloudex2ultra I am welcomed to the new My Cloud OS 5. I was expected to see a page prompting to enter a new password. Instead I was asked to log in as admin, but my new OS5 password is not accepted, nor is the old OS3 password (“incorrect credentials”). After several trials a message appears: “The user name or password you entered is incorrect. Visit here for assistance.” This link directs me back to the page showing how to reset My Cloud OS 5 device. I seem to be in a never ending a loop.

What can I do to access the dashboard?

40 sec reset solved the problem.

1 Like

I have the same problem, any solution found?

How did you solve this problem. Please let me know.

I just left it until it is updated to the next version of OS automatically and the problem solved.

Thanks for your reply!
Without accessing dashboard, how could you update to next version of OS. I thought you had problem with OS5.

Automatic update function was already enabled in the OS settings, so it updated itself automatically. if it’s enabled for your device so just wait for the next version, it will update automatically and may the problem be solved.

1 Like

Hope the auto update setting is done on mine too! Or should we do it manually?

I think that it is enabled by default. If you didn’t change it before, I think it will be already enabled.

1 Like