After a year of working well my WD Elements Desktop is not recognized by any of my computers

Hello all. I’ve had it plugged in and working well with my XP for over a year and just the other day I clicked on a folder and it offered to format, I cancelled then restarted my computer and windows wouldn’t open until I disconnected the HD. Tried it in two other computers.The light blinks constantly but does not get recognized by any of them. I downloaded WD Data LifeGuard Diagnostics. Didn’t recognize. I do get the sound when I connect though but no drive letter in My Computer. Any Ideas? Thank you.

I just plugged it in and put it up to my ear. The computer made the right sound, then I heard it start spinning and ticking then a constant click while it spins.The light is blinking continuously but It’s still not showing up though…

I have a My Book Essential 1TB running once a week for backups on a win 7 machine. It is about 6 months old.

Last night it did the same thing - stopped working in the middle of a back up. The drive clicks but the backup was frozen.

After killing the process and trying to reboot, the computer hangs on the bios screen.

Disconnecting the usb, the drive continues to click (a nice *hard* click, btw) until power is disconnected.

Computer then boots normally.

Applying power to the My Book (no clicking), I plugged in the usb. Drive was not recognized and the clicking started immediately.

This really does appear to be a hardware problem, but I’d love to hear differently, as all my eggs are on this one backup drive at the moment, and I’m loathe to buy another WD drive to replace it.

From the Knowledgebase:

For WD external drives with power adapters

 

  1. To test if the drive is getting enough power, plug the power adapter directly into a wall outlet. (If the power outlet has a lot of devices plugged into it, the drive may need to be plugged into a different outlet).

 

  1. Remove the data cable from the drive. Turn the drive on. If the drive does not click and spins up normally with the data cable removed, the cable may be faulty. Replace the data cable that was being used and try again.
NOTE Note: If the drive won't turn on with the cable connected to the PC, please try using another cable with the drive.
  1. If the drive stops clicking then the drive is good, but the cable is bad. If the drive is still clicking after you remove the cable (or try another cable), The drive has failed and will need to be replaced. Information about in-warranty replacement is available in  Answer ID 8: How can I replace a product under warranty?.

In our case, the drive is bad.

 Hello, I have a similar problem with two My book drives - 2TB - 3TB both are full.

These drives spin up fine, no noise at all however they are not recognized in my computer,

disk management or device manager.

I did some Google research and learned that you cannot simply remove the hard drive and install

it into a desk top PC because windows will  be unable to read the data since it is encrypted as its

written to the disk through the control board.

Obviously both of these My Book drives are in need of new control boards, I have gone through all of the elimination

checks recommended to connection of the drives in these forums.

If anyone knows of another solution before I purchase new control boards please come forth.

The 3 TB is still in warranty however, I just don’t want to swap all my data for another blank drive.

Control boards are about $25 each, I feel I have spent enough for these drives already.

                                                                            Regards