Adjust samba time out settings

Just got a new 6tb my cloud. I’ve got some devices that access a share via samba, the problem is sometimes I pause them for an extended time period, causing the my cloud to time out and disconnect from the device. Now I know enough to know that I need to ssh into the drive to find the smb settings, and that it will void my warranty. I’ve attempted to change the dead time variable to extend the connection time but this doesn’t seem to work.
Do I need to adjust smb settings for the share itself? Where do I go to do this?

Hello, unfortunately I do not know how to accomplish this, lets see if one of the more knowledgeable users here can provide some information or tips.

There is an option in the smb-global.conf file located in the /etc/samba folder called deadtime. According to deadtime is the number of minutes of inactivity before a connection should be terminated. Apparently this value is set to 30 (minutes) on the My Cloud.

One could try to change that value to suit their needs, if one hasn’t done so already. After making the change one would probably have to either restart the My Cloud or stop then restart the Samba stack/service.

One has tried, and it didn’t appear to work, I will try one more time to see if this helps (set it for a full 24 hours lol

Did you restart the My Cloud (or stop/restart SMB/Samba services) after making the change? I might help to restart not only the My Cloud but the computers to which you are making the setting change for as well.

Yeah that’s what I’m trying to make sure it works, going to leave it overnight to see if it lasts.

So, all that has been done now and it still times out. Could each share have its own smb configuration file?

Here’s a couple screen shots of the drive, two show the main folder and the last shows the contents of the samba folder, is there anything here that could help?