Acronis True Image cloning fail

My 4 yo Hitachi 1TB HDD is reallocating sectors at an increasing rate (now at 99) and I just bought a WD10EZEX 1TB to replace it. I’ve done the full chkdsk /f on the old drive and repairs were made.
Downloaded the WD edition of Acronis and mounted the new drive up, then proceeded to attempt a clone. After choosing the source and destination drives and the Auto option, the PC reboots to a DOS screen as follows
Loading operating system
Starting Acronis loader
After a few seconds the screen blanks, followed by…nothing. A total blank.

I waited over an hour before hitting the power button to off. Needless to say the new drive is still unbootable. Tried again with the same result.

I thought about taking the manual option instead of auto but doubt that would help. There’s only 1 partition involved.

Any ideas, folks? Cheers!


I recommend you contact WD support directly for assistance with this issue.

I rang support but they couldn’t help but suggested I try Acronis. Looking at their website I read that the sector size needs to be the same for both drives to allow cloning, which makes sense.
The Hitachi has 512 B/sector and if the WD has 4096 Byte sectors I’m up the creek, but it still should not cause the software to stop working with no error message.