Access to my pass protected Passport suddenly denied

Hi there
I have been using my WD Passport for almost 1 year and since 2 months I have protected it with a password.
Until noon today everything has worked regularly using, the WD Drive Unlock.exe.
In the afternoon things have changed. Every time I click on the WD Drive Unlock.exe I am prompted with a request for password which I write and I am told that the unit is unlocked. The problem is that the unit is unaccessible (access denied) and there is no way to enter.
If I open DOS and browse through the various directories, everything is there, so I suppose my files are not lost.
Is this a problem with the password or is it a prblem with the disk itself?
I ran a chkdsk and found there were several errors, so I ran chkdsk /f and corrected them but still no way to access my data.
Needless to say, the data on this HD is very important.
Can anybody please give me a hand on this? I’d be really very grateful. Thank you in advance.

PS: my software is in Italian so maybe I have not used the correct terms.


It is possible the partition is corrupted. You can try using a data recovery software to try and recover the files. You can also contact WD Support directly for assistance with this issue.