Access to My Cloud from abroad on new computer

I bougth a new computer abroad and I need to access My Cloud. Web access continues to give certificate problems and link to solve these problems doesn’t work. How do I get access?

Have you given the computer access to your My Cloud? Is your new computer, device, shown as connected? See example image below.

Click on, tap or activate image to enlarge it.

I am 3000 km away from home, so no…Is it not possible to access from a new computer from the web?

What certificate problem? Can you post a screen shot of the certificate error? What is the “link to solve these problems”? What web browser are you using to access the web portal? Have you tried using a different web browser?

First response after logging on. Result when clicking on link:

Tried both Chrome and Internet Explorer…

And access is working from my Android phone…

What about Firefox?

What are you using on your android phone to access the My Cloud? A web browser or the WD My Cloud app for Android?

Have you tried using the My Cloud Desktop program for remote access?

WD My Cloud Desktop for Windows:
WD My Cloud Desktop for Mac:

The app on the phone is working. Installed WD My Cloud Desktop for Windows. After signing in with email and password, I get the response “Cannot connect to device”. As I said, access is work on Android phone.

Sounds like a specific problem with that computer. Have you tried disabling any security software/firewall on that computer? Have you tried disabling any web browser plugins (that disable scripting or advertisements)? Do you have another computer you can test in your remote location to see if the problem is isolated to that one specific computer or a problem with the remote ISP/broadband provider?

Could be the specific configuration of that computer is blocking proper access (some how) to using the remote access feature of the My Cloud.

That is also my conclusion. It worked on old computer. Had to buy a new computer on location. But yes I tried to enable pop-up, allow the outgoing etc. I will continue trying :slightly_smiling_face: Thanks

Non commerical version of Teamviewer 12 on both computers helps.