Access device settings in Big Sur or even just reset my password for MyCloud Home

I’ve had a MyCloud drive for 3 years or so, and mostly just use it with macOS and my iPad. Everything works fine. But I had a power outage today, and wanted to access the settings using the WD MyCloud app on macOS. But apparently that app hasn’t been updated for Big Sur, because when I launch it, I get an ‘App needs to be updated’ message.

Looking online, I’m not able to find an update for that app. I did find the ‘My Cloud Home’ app, which I’m assuming is a replacement for the WD MyCloud App? No idea if that’s true though. So I installed it, yet it’s not accepting my username/password. I’m entering the user/pw that is being accepted on files.mycloud.com. Not sure if that’s the one I’m supposed to be using. So I tried clicking the ‘Forgot Password’ button in the MyCloud Home app, and it takes me to https://home.mycloud.com/reset-password/new and then I never get the email to reset the password. I’ve tried it 3 times, and no, it’s not in my junk mail. The email just never arrives despite saying it has been sent. So WD seems to be failing on all fronts for me here.

So for the love of god WD, all I want to do is access my device’s management settings. How am I supposed to do that in macOS Big Sur now?

Never mind. I figured it out. Apparently they just nixed the actual .app but you can still just reach it by going to http://wdmycloud.local/UI/ in a browser. That’s all I really wanted.

Note that the My Cloud Home is a completely different device with a different operating system and features/options. You either have a My Cloud or a My Cloud Home.

This subforum (My Cloud) is generally for the single bay/single drive My Cloud. The My Cloud Home has their own separate subforum.

Edit to add: Further the My Cloud Home does not have a Dashboard. WD Support has a knowledgebase article on this issue:

Further the My Cloud Home uses a different web link for remote access. If you are using the My Cloud Home web portal to access the My Cloud it will fail. Make sure to select the correct device when using the web portal.

Ya I already figured the issue out as my second comment explains. The only reason I installed the Home app is because they seemingly have no update or replacement for the WD MyCloud app. So users who have been using it for years are just left wondering how to get to their management settings. And as a developer myself, I can tell you it’s pretty bad form for an email reset to say it was successfully sent, if the email isn’t actually registered for that account, which is apparently what was going on.

But luckily I had bookmarked the local settings page for my device at one point, and that still worked. So I’m all set. Thanks though