Access denied to folders on a network external drive

Hi everyone,

i have a WD My Book World Edition II WDH2NC20000 and i cant access some of my folders in my main projects folder. I tried both of my macbook pro computers. I saw some other people had the same issue with external hard drive but via usb connection. the solution was to write some code in terminal in order to regain access no one though had the same problem with a network drive. 

So whenever i try to open a folder this message comes up:

The folder can’t be opened because you don’t have permission to see its contents.

I tried also to solve the problem via the “get info” option of the folder in order to change who has access but again nothing changes.

Does anyone know a solution to this:

Thanks in advance,

Labridis

error2.jpg

error.jpg

Hello,

I have found these threads in Apple support forums. You should take a look at them.

https://discussions.apple.com/thread/2135793

https://discussions.apple.com/thread/2135793?start=75&tstart=0

1 Like

Thanks for the post but i am having the problem ever since i bought the WD drive and i was on Leopard back then. I dont think it has to do with the OS i am using but with the drive itself. WD suggested to reset the drive and erase all credentials so then all folders are in public folder. I will try it and i will let the forum know.