A buffering problem?

Bought a new Live Hub a week ago, updated to newest firmware and have watched some movies with it. Noticed some choppy parts with the films but have managed until now when i tried to watch Alien in 720p .mp4 format. The movie runs fine for about a minute and then starts stuttering and loses audio. When i rewind it back a bit and start over, it plays nicely for one more minute and then starts stuttering again etc. This makes the movie practically unwatchable.

Could it be that WDTV’s advance buffer size is way too small and that’s why it is stuttering? Has anyone else ever experienced the same?

Would the best solution be to go back to the store and claim my money back…?

What is the source of the movies?   A NETWORK SHARE, The Local Drive, a Media Server?   

How is your WD connected to the network?   How is the SERVER connected to the network?

Oh sorry, forgot to mention that. The source is Live Hub’s own hd.

Please post the full TEXT output of MEDIAINFO for such a file.


Complete name : \\WDTVLIVEHUB\WDTVLiveHub\Alien.mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom
File size : 2.50 GiB
Duration : 1h 55mn
Overall bit rate : 3 089 Kbps
Encoded date : UTC 2010-10-03 15:03:08
Tagged date : UTC 2010-10-03 15:03:08

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 1h 55mn
Bit rate mode : Variable
Bit rate : 2 720 Kbps
Maximum bit rate : 24.0 Mbps
Width : 1 280 pixels
Height : 544 pixels
Display aspect ratio : 2.35:1
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.163
Stream size : 2.20 GiB (88%)
Writing library : x264 core 104 r1677 19df41a
Encoding settings : cabac=1 / ref=4 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex 

/ subme=4 / psy=1 / psy_rd=0.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=1 / 

8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=3 / 

sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / constrained_intra=0 / bframes=3 / 

b_pyramid=0 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=1 / keyint=250 

/ keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / 

bitrate=2720 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / 

qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
Encoded date : UTC 2010-10-03 03:56:21
Tagged date : UTC 2010-10-03 15:06:32

ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 1h 55mn
Bit rate mode : Variable
Bit rate : 366 Kbps
Maximum bit rate : 456 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Compression mode : Lossy
Stream size : 303 MiB (12%)
Language : English
Encoded date : UTC 2010-10-03 15:06:03
Tagged date : UTC 2010-10-03 15:06:32

I managed to get this phenomenon on film. First the video starts ‘pulsating’ and then after a while ‘catches up’ with hyperspeed and plays nicely for a while until starts again…


How did you encode that video?   I’m not certain, but I don’t think ISOM is supported.

The encoding is not done by me so i don’t know. Feels odd if the codec is not supported as my previous player (ancient WDTV HD) played this same file without a single hiccup.

You might try converting it to mkv (h264) using something like MKVtoolnix, I don’t know if it will handle .mp4(isom) files, since I’ve never dealt with them, but if it will it should only take a few minutes to re-encode.

If that doesn’t work, you can try Handbrake to re-encode the file, it will usually handle just about any unprotected file you can throw at it.

Thanks, i have Handbrake already encoding the file into mkv. See what happens… What’s odd is that i also  have other files in isom but have not noticed any (significant) stuttering with them.

Alright! Seems that the problem is solved (well, at least sort of…) as i downgraded to 2.03.24 and watched Alien for 15 minutes without a problem! Thanks for all the help!

I hope this bug will soon be fixed. I have had the same problem with a 720p .mp4 file (from the WDTV Live Hub harddisk) which sometimes stops and video stutters, audio is gone and after that plays again. It happend quite a few times in a movie of 1.30 hour. This problem still occurs in the latest firmware 2.07.17

I agree i just got done report this same isssue to a rep, So not sure if this is fixed yet …i have to re-encode all my dvds i just encoded useing AVS to AVI (Divx), it does not happen all the time some times works great some times it does what you get also …flutters and loses sound

Yep! after 2.03.24 audio play back issues.

yeah i upgraded to the newest firmware (08?) and now it stutters for me too.