503 error and relay connection

Hi
I get 503 error while listening to music on iphone 5s through mobile network. I can connect to WD My Cloud disc but after a few minutes of playing music via My Cloud app I get 503 error, and can no longer connect through mobile network also with other devices. I think that iphone is triggering this error and till now it happens only when playing one specific album. Through WiFi everything works flawlessly. My WD My Cloud disc is connected to tp-link router, which is connected to technicolor modem/router. I have tried a few solutions form this site. Unfortunately, I did not succeed.
I have found some interesting clues. I can connect through mobile network to WD My Cloud disc only if connection is in relay mode. After setting static IP on WD disc and reservation IP set in TP-link router, connection status is “connected (Port Forwarding Connection Established)”. But in that case I get 905 error when I try to connect through mobile network on all devices. I have tried manual port forwarding (Tp-link router supports Upnp) with no results. After a few hours of struggling with WD My Cloud disc and routers setup I can tell that I don’t know how to establish non relay connection. Apparently “connected (Port Forwarding Connection Established)” status changes after some time to “Connected (Relay Connection Established)” in spite of static IP on WD disc and IP reservation on tp-link router settings.

How can I solve problem with 503 error and establish non relay connection?

This means you’re using the relay servers of My Cloud.

Please check your TP-Link router and see if it is using ITSELF as the DNS server or the DNS servers provided by your ISP. If so, try changing the TP-Link router and My Cloud to use google dns server 8,8,8,8 and 8,8,8.4 and reboot everything so that ALL are using google DNS servers.

Let us know the results.

Hi,
thank you for your help.
My Cloud used tp-link router IP adress as first of DNS serwers.
I had changed DNS on tp-link and My Cloud disc to google DNS 8.8.8.8 and 8.8.4.4.
At first connection status was “connected (Port Forwarding connection established)”, but after a few minutes status changed to “Connected (Relay connection established)”.
Should I change DNS also on technicolor modem/router? I can change it only if I set WAN connection type from DHCP to static IP. Maybe the problem is technicolor modem/router setup? Port forwarding is enabled on this modem/router, but I don’t know how to check if it is working.

APOLOGIES! I missed the most important sentence. :frowning:
Your my cloud is Double NAT (behind two routers) so it will always be in Relay Mode unless you port forward through both routers (not recommended).

Even if in Relay Mode, remote access should work, but there may be something on the modem/router blocking, metering or filtering traffic.

Why double port forwarding is not recommended? What about other options to resolve double NAT problem? I’ve already tried with DMZ on Technicolor router, but it didn’t helped. I can try to put Technicolor router into bridge mode.

The question you should be asking is why are you double NAT’ing in the first place? What do you hope to gain by doing it?

Generally when you put a second router behind the main broadband router you would disable the DHCP server on the second router and connect the first router to the second by running the Ethernet wire to one of the four networking ports, NOT the WAN/Internet port) of the second router. Some routers also have the option to reconfigure the WAN/Internet port to disable the firewall on the router and turn that port into a fifth networking port. If this is the case on the second router go ahead and reconfigure the WAN/Internet port so its not activating the firewall.

You should be able to find directions on re-configuring your second router to sit behind the main router by doing an internet search using the second router’s make/model.

My first router (technicolor) is also modem from my ISP. Unfortunately, it doesn’t get along with macbooks and my ISP can do nothing about it. So I’m using tp-link router for WiFi. But if I understand you correctly I’ve probably connected them in a wrong way.
Correct me if I’m wrong. The ethernet wire should go out from one of technicolors (first router) networking ports and go in networking ports of tp-link (second router)? Will this resolve double NAT problem, and/or problem with relay connection? I have tried this setup and IP addresses look like there is only one router 192.168.0. … instead of 192.168.1. … . But My Cloud is failing to connect to cloud and I don’t know how to connect to setup page of second router (Tp-link), because its IP address has changed :).

You have several issues to content with. First is to access the TP-Link router’s administration page and disable the TP-Link router’s DHCP server. When you do so you should set the TP-Link router’s IP address to the same IP address range as the IP address range used by the DHCP server on the Technicolors. For example of the Technicolors router DHCP server is using the 192.168.0.x range then configure the TP-Link router to have a static IP in the 192.168.0.x range (for example 192.168.0.2).

Once you have disabled the TP-Link’s DHCP server you can then connect an Ethernet cable from the Technicolor router’s networking port to one of the four networking ports on the TP-Link router. What you are doing in effect is turning the TP-Link router into an ethernet switch/hub by using one of the TP-Link router’s four networking ports. The WiFi on the TP-Link should continue to work and hand out (unless the WiFi has its own DHCP server) IP addresses from the DHCP server on the Technicolor router.

Next, you may want to reset your My Cloud to default by performing a 40 second reset. Then reconfigure the My Cloud to have a static IP address by either assigning or reserving a static IP address for the My Cloud in the Technicolors DHCP server or by setting the static IP through the My Cloud Dashboard > Settings page. Next enable Remote Access through the My Cloud Dashboard > Settings page and wait to see what it indicates as its Remote Access Connection Status. Once it says connected try accessing the My Cloud using the MyCloud.com web portal to see if remote access works.

If remote access still doesn’t work you can try to change the Remote Access Configure settings from Auto to Manual then access your Technicolors router and configure PORT FORWARDING within that router’s administration page to forward ports 80 and 443 to the IP address of the My Cloud.

Because some broadband providers block port 80 and or port 443 you can change the Remote Access Configure settings from Auto to Manual and specify a different set of port numbers like 8080 and 8443. When you do so remember to change or set the same values for the Technicolors Port Forwarding as well.

If you are still having trouble then perform an internet search for your TP-Link router model and use the search term “second router” or “TP-Link behind a router” for directions for how to configure the TP-Link to sit behind another router. Also do a internet search for the Technicolors router model and the words “port forwarding” and you should find instructions on how to configure port forwarding with the Technicolors router.

1 Like

Thank you very much for your help. It looks like everything is working now :)! Connection status:
“Connected - Port forwarding connection established” and no errors on iphone.

Accidentally I did one thing differently from your suggestions. I’ve set tp-link router’s IP address to 192.168.0.2 but technicolor router DHCP IP address range starts from 192.168.0.10 although technicolor router address is 192.168.0.1. Can I leave it this way or should I change tp-link IP address to 192.168.0.11?

It’s working.
It’s on the same subnet (192.168.0.xxx).

Leave it as it is, provided it’s set up as 'fixed or ‘static’ IP, or ‘always use this address’.

You can probably leave the TP-Link IP Address set to 192.168.0.2 as long as no other devices on the local network use that address. What you want to do is have the TP-Link IP Address using an address outside of the address range the Technicolor DHCP server will use to hand out to clients on the network. Often times you can access the DHCP server settings and see what the range of addresses the server will hand out to clients on the local network, then select an address outside of that range.

Thank you guys. 192.168.0.2 is outside of the address range of the Technicolor DHCP server (192.168.0.10 - 192.168.0.254).