500 GB limit for old Dell?

Hi guys,

I am trying to install a new hard drive for my Dell Dimension 2400.

It is a 10 year old computer, but it still gets me where I need to go.

The boot screen comes up and identifies my old 500 GB drive and it’s size:

0 WDC WD5000AADS-00598 – 476940 MB

But for the new hard drive, only the model # comes up. Not the size:


Nothing progresses after that, no matter what I do. As soon as I turn the

power on, I press F2 to enter setup, F12 for boot order, and F4 to enter the

raid utility, but nothing happens.

My guess is that the bios has a 500 GB limit, and doesn’t like my 1TB drive.

I don’t think it could be my SATA card, which is only about 5 years old.

I have tried limiting the speed using a jumper, and have formatted and partitioned

the 1TB into three logical drives. (using another PC) But I get the same result.

What do you think? Should I return the 1TB drive to Best Buy, and buy another

500 GB drive? Or is there some workaround for this?

Hello, check if you have any BIOS updates available for your PC, I also recommend you to check the Delll web site for more information on what is the largest HDD supported.

One way to determine whether there is a 500GB issue would be to cut the capacity of your drive using a tool such as HDAT2. I would cut the capacity to 120GB, say, to ensure that you are not exceeding the 28-bit LBA limit. If the drive’s capacity is still not properly reported, then this would point to some other problem.

I actualy went and bought a 500 GB drive.  The bios recognized it, no problem.

I tried the freeware Acronis clone tool, but it was a little buggy.  I downloaded Clonezilla. (freeware)

It worked flawlessly.  I was very impressed with it.

As for the 1TB drive,  a previous poster on this forum had success with using two jumpers.

He used 5&6 and 7&8, but that did not work for me.  I tried every combination with two jumpers,

but with no success.  If no one has any other ideas. I guess I’ll return it.

The bios is the latest, BTW.  (A05)