4TB My Cloud disappeared- Fast blinking blue light! HELP

Without the USB flash drive, mycloud does not boot, it does not appear on the network.

The router is set to dhcp and there’s only the notebook & mycloud connected. I kinda doubt there’s a temperature issue, and about the ethernet, whether it was connected or not the ethernet port, when the problem started I got blue blinkg light, after using
the USB flash drive, (when I took it out) it is red blinking…

Is there a command to check the whole disk from the telnet window?

When you power on the My Cloud. The led first blinks purple. Then goes to a flashing blue. Once the My Cloud has completed the boot process the led goes solid blue. I definitely would try the monitor. If the flashing blue turns red the most probable cause it no network connection. The main problem with this device is that you need to be able to do a vulcan mind probe is see what is going on.
Another thing you could do is when you have the telnet connection you could try to mount the sda2 partition. The comands would be
mount /dev/sda2 /mnt
cd /mnt/.systemfile
cd log*

The output of the ls command should show log files. if you cat the files look for errors.
I think the command get will download the file to your laptop. From there you can use notepad to look at the file.

Yes, it does starts purple, then turned blinking blue, now it starts purple, 30 seconds or so of blinking blue, finally changes to blinking red…

BUT, if there’s a network problem, how come I can boot up using the pendrive and telnet and do stuff?

One thing that I found extremely weird, was that BEFORE this problem, on the router, the MAC ADDRESS was one, and when I used the flash drive to boot, the MAC ADDRESS is a different one (!!!)

I’ll try your suggestion, now…why sda2? what’s on there? the boot partition?

Then…" From
there you can use notepad to look at the file" What should I look for?


sda2 on a gen2 is the data partition. There should be several log files called
mycloud.log orion_cm.log user.log wdmcserver.log
mycloud.log.1 orion_cm.log.1 user.log.old wdmcserver.log.1

The .1 is the older log.

I just tested the telnet connection on my gen2. The commands do work. If using putty you can setup putty to log the console to a file. The file is called putty.log
mount /dev/sda2 /mnt
cd /mnt/.systemfile/log*
ls -l

Not sure if this will help others but the following thread details what worked for one person to fix the fast blinking blue LED post gen 2 firmware update.

1 Like

Success!!! This just worked for me! Mine bricked the same night as everyone else… I’ve been quitely (and painfully) watching these boards. Thank you SO much for everyone’s time and effort. Please check out that fix. The e2fsck was the key for me.


Thanks for the try…but no luck, I followed all the steps succesfully I guess, but when I boot without the pendrive, the drive boots to a red flashing light, no luck finding it on the network, thus no telnet, no pinging… I even tried, during one of the runs, esfsck to sda1 - 7 just to see if that would do anything… but no luck

Ok, so I did what you told me, here’s the result

mount /dev/sda2 /mnt
cd /mnt/.systemfile
cd log*

/mnt/.systemfile/log_WCC4E2FYXJT4 # ls
-rw-r–r-- 1 root 0 0 Mar 27 2019 mycloud.log
-rw-r–r-- 1 root 0 244 Mar 27 2019 mycloud.log.1
-rw-r–r-- 1 root 0 5074 Nov 17 2017 orion_cm.log
-rw-r–r-- 1 root 0 224400 Nov 17 2017 orion_cm.log.1
-rw-r–r-- 1 root 0 57238 Mar 27 2019 user.log
-rw-r–r-- 1 root 0 103473 Mar 10 2019 user.log.old
-rw-r–r-- 1 root 0 0 Apr 21 2017 wdmcserver.log
-rw-r–r-- 1 root 0 0 Apr 21 2017 wdmcserver.log.1

/mnt/.systemfile/log_WCC4E2FYXJT4 # cat mycloud.log.1
2019-03-27T03:00:03.707537-03:00 di=UZOWkQV0Zh notice upload_firmware: { “msgid”:“alert”, “level”:“info”, “code”:2026
2019-03-27T03:00:17.528376-03:00 di=UZOWkQV0Zh notice upload_firmware: { “msgid”:“alert”, “level”:“info”, “code”:2004

/mnt/.systemfile/log_WCC4E2FYXJT4 # cat orion_cm.log
2017-11-17T09:43:33.694360-03:00 di=UZOWkQV0Zh 3 MyCloudDrive OnBoardingD: OnBrdNetLocComm::httpPostOrPut curl_easy_perf
orm Error: [Timeout was reached] URL: [https://discovery.wd2go.com/on-boarding/api/1.0/rest/onboarded_devices/0090A9ECE
2017-11-17T09:43:33.694534-03:00 di=UZOWkQV0Zh 3 MyCloudDrive OnBoardingD: OnBrdNetLocComm::updateRemoteOnboardingInfo -
httpPostOrPut failed to create/update onboarding info for url https://discovery.wd2go.com/on-boarding/api/1.0/rest/onboa
2017-11-17T09:48:33.696228-03:00 di=UZOWkQV0Zh 3 MyCloudDrive OnBoardingD: OnBrdNetLocComm::httpPostOrPut curl_easy_perf
orm Error: [Couldn’t connect to server] URL: [https://discovery.wd2go.com/on-boarding/api/1.0/rest/onboarded_devices/00

… (many lines 'till this is the last one)
2017-11-17T10:35:24.616011-03:00 di=UZOWkQV0Zh 3 MyCloudDrive OnBoardingD: OnBrdNetLocComm::updateRemoteOnboardingInfo -
httpPostOrPut failed to create/update onboarding info for url https://discovery.wd2go.com/on-boarding/api/1.0/rest/onboa
/mnt/.systemfile/log_WCC4E2FYXJT4 #

/mnt/.systemfile/log_WCC4E2FYXJT4 # cat user.log

The first part, I guess it was OK…then we come to 2019-03-27… I think what happened was, indeed, the firmware was automatically downloaded, but failed to be applied…or after it was applied REST API Failed to return success, which is no good (not sure I understand exactly what I means)

2019-03-26T21:48:13.985779-03:00 di=UZOWkQV0Zh 6 MyCloudDrive SAMBA: CIFS: [ipv4:] connected to [Video] as user [maracanazo].
2019-03-27T00:00:02.548055-03:00 di=UZOWkQV0Zh 6 MyCloudDrive random_chk_central: Set check central server at 2:47
2019-03-27T00:01:06.087076-03:00 di=UZOWkQV0Zh 5 MyCloudDrive root: Rotated atop, atop_size=11619378 atop_upload_size=998
2019-03-27T00:47:04.032471-03:00 di=UZOWkQV0Zh 6 MyCloudDrive SYSTEM: Downloading firmware update.
2019-03-27T00:47:05.653414-03:00 di=UZOWkQV0Zh 3 MyCloudDrive root: WD NAS: Email alerts REST API failed to return Succes
2019-03-27T02:30:02.201596-03:00 di=UZOWkQV0Zh 6 MyCloudDrive sntp[14044]: sntp 4.2.8@1.3265 Fri Jan 9 06:42:54 UTC 2015
2019-03-27T02:30:01.851882-03:00 di=UZOWkQV0Zh 6 MyCloudDrive sntp[14044]: 2019-03-27 02:30:02.610861 (+0300) -0.760424 +
/- 0.533911 time.windows.com s2
2019-03-27T02:30:06.270250-03:00 di=UZOWkQV0Zh 6 MyCloudDrive RTC: Set System Time.
2019-03-27T03:00:03.714376-03:00 di=UZOWkQV0Zh 6 MyCloudDrive SYSTEM: Installing firmware update.
2019-03-27T03:00:09.606200-03:00 di=UZOWkQV0Zh 5 MyCloudDrive root: Rotated atop, atop_size=3129962 atop_upload_size=3422
2019-03-27T03:00:17.534993-03:00 di=UZOWkQV0Zh 6 MyCloudDrive SYSTEM: The firmware was successfully updated to
2019-03-27T03:00:18.364693-03:00 di=UZOWkQV0Zh 3 MyCloudDrive root: WD NAS: Email alerts REST API failed to return Succes

Any wisdom that you can share?

Here’s what I did once it started blinking red:

After I went through all the directions and telnet stuff, it has you pull the plug and remove the USB. Once you plug it in it’ll start blinking blue then change to blinking red. At that point, in whatever web browser you use, type in the IP address listed on the bottom of the MyCloud and hit enter. You’ll then get to the MyCloud safe mode GUI. It’ll say something like, the firmware is corrupt and it’ll give you an option to browse your computer and upload a new one. I used My_Cloud_GLCR_2.31.163. Then I clicked apply. It uploaded the file and then says it’s rebooting. I patiently watched the MyDrive blink blue for, what seemed like forever, then bam! Solid blue and back to normal!

I think you’re close. You just need to go to the IP in a web browser. Hopefully that helps! I’m happy to answer more questions!

…but the problem is that once I remove the USB and the led turned to flashing red I DON’T FIND THE DRIVE ANYWHERE. I used netscan to scan all the IP addresses on the network and I only see the router and the notebook, that’s it. So there’s no IP to enter on the browser.

One thing that I still can’t get out of my head is that the MAC ADDRESS is different now that I’m using the USB drive, that the one I had a reservation for on the router (which was the same one as written on the bottom of MyCloud’s casing)…

The REST message is also showing in my gen2. So I don’t think that has anything to do with your problem. The other thing that i see is that the last entry in your log is Mar 27 at 3am.
Two things. I see that you looked at the Success recover my MyCloud 3TB. This should work.
But a last resort to get your data would be to setup a USB as big as you think you would need.
Then telnet into the device.
mkdir /mnt/sda
mkdir /mnt/sdb
mount /dev/sda2 /mnt/sda
mount /dev/sdb1 /mnt/sdb
cd /mnt/sda
Now you have a list of folders on your data partition. You can now copy file from your current location to /mnt/sdb.
cp /mnt/sdb This will copy one file
cp -r /mnt/sdb This will copy foldername and all files in the foldername
If you want to put them in a different folder on the USB. Just mkdir /mnt/sdb/
and change the cp /mnt/sdb/

I hope this helps.

Thanks for the tip, the problem is that I have almost 1Tb of info to copy, mainly videos. Is there any way to copy (using the flash pendrive boot) from the drive to the PC?

Gotcha. I had similar problems finding the IP initially, during the telnet phase though. Mine ended up being labeled Marvell Semiconductors Inc. weirdly.

Anyways… (and sorry if you’ve already answered this) once you get to the blinking red light stage have you just tried typing the IP listed on the case into the browser and seeing what happens, regardless of not finding the IP on the network?

If you’ve gotten that far and everything has gone smooth it just seems to me that you’re close… at least in my experience with my drive. Again, I’m no expert though.

Not that I know of. I tried to mount a network drive. It didn’t work. I did put the boot USB in a hub and booted. I then put a 4TB My Book on the hub. It saw the My Book. But I could not mount it. I think it was becasue the MY Book was formated as NTFS. But if you have a My Book or some other large USB device. You could try to set up the device the same as you setup the thumb drive.
I hope this helps.

PS when you add another device to the hub. It becomes /dev/sdc. If you add two they become /dev/sdc and /dev/sdd.

Ok…here’s today’s update - I stayed up until 3AM trying to figure this sh*t up… BUT even though I still haven’t got back my drive (yet) I accomplished some progress

A) I ran e2fsck /dev/sdaX (X being 1-7). followed the rest of the steps…nothing, still could not find the drive on the network

B) On a moment of clarity, I made a change to the router that I’m using to recover the drive (not the original where MyCloud was running). I changed to the same IP range of the first router.… any THEN, after running all the commands and rebooting without the flash drive VOILA! I found it !!!
My guess is that no matter the 5 and 40 seconds reset, and all this stuff that I’m doing, the IP address must kept the same.
Anyway, I found 2 addresses, the ORIGINAL IP Address where the router was and one prior to that one (167 and 168)
I ran arp -a from command windows, 167 had a MAC Address, 168 no. I could ping both (REALLY WEIRD)

I typed both IPs on a browser and, on the one that had no MAC address, nothing… BUT…on the one with the MAC address, I FINALLY GOT THE RECOVERY INTERFACE!!!

The message was that the firmware was corrupt and that was the reason I had entered a recovery interface.

I thought my problems were ALMOST behind me… I located the firmware, 2.31.163, and HIT ENTER. A wheel started spinning on screen… almost 15 minutes later, I did something stupid, I unpurposedly went to another URL. got inmediately back, and a couple of minutes later, the spinning wheel stopped… I thought that was it. So I unplugged the drive, plugged it back on, and… RED LIGHT… GRRRRRRRRRRRRRRRR :rage::rage::rage:

It was pretty late by then, around 2:45AM, so, since I could access the recovery UI, I did so, and tried upgrading the firmware again (2.31.163). This time the wheel stayed spinning on for over 30 minutes. At 3:15 I went to bed, hoping to wake up to a nice surprise, but no… still red, still recovery, still 2 IP addresses.

My guess is that changing the URL during the first upgrade must f*cked up the process,
Is this reasonable thinking?

I will do the whole thing, from scratch (flash drive, steps, etc) tonight.

Will keep you posted.

Fingers crossed :crossed_fingers:

1 Like

…still no good news, I’ve got Fox_exe to help me with some tips, he told me that maybe some of the partitions were bad. so he (or she?) gave me a series of steps to follow, the problem is I CAN’T do one of the steps, and now i’m stuck because I believe I erase some of the partitions… (if I’m correct, tha is, I understood correct what I was doing, I erased ALL OF THE PARTITIONS EXCEPT for where the actual data is)
dd if=/dev/zero of=/dev/sda1
dd if=/dev/zero of=/dev/sda3
dd if=/dev/zero of=/dev/sda4
dd if=/dev/zero of=/dev/sda7
mkpart ext4 /dev/sda3
mount /dev/sda3 /mnt/root
mkdir /mnt/root/boot/
cd /mnt/root/boot
etc… usual instructions

The problem is with “mkpart ext4 /dev/sda3” . Because as a return I get /bin/ash: mkpart: not found

and now I’m screwed. Any wisdom from ANYONE out there on how to solve this?

PS: (I now the data is still there, I even succeeded copying one file from the disk (mycloud) into the flashdrive)…

You should not have zero’d those partitions. /dev/sda4 contains some system data. Not sure how to recover this data. /dev/sda7 is the /usr/local/config partition. Using the unbrick procedure will put all of the partitions back. The /dev/sda3 partition contains the uImage uRamdisk and image.cfs. These files allow the system to boot. Not sure if the sda4 and sda7 partitions will be rebuilt. The /dev/sda1 partition is used as the swap partition.

…yes, maybe i shouldn’t and I also should have set firmware update to off :rage::rage::rage: the I would have save me a lot of trouble…

About the unbrick procedure, I tried it, BUT here’s what happens

/ # mkdir -p /mnt/usb /mnt/root
/ #
/ # mount /dev/sda3 /mnt/root
mount: mounting /dev/sda3 on /mnt/root failed: Invalid argument
/ #

any input about the mkpart ext4 /dev/sda3 command? because if somehow I can run this command, everthing else should be ok (according to Fox_exe instructions…)

did you do the mkfs.ext4 /dev/sda3?