4tb 40EZRX size problem shows as 3 TB

My 4tb drive somehow lost some of the date. IT was full with 4TB of movies and somehow it started reading only a certain part of the data. I tried to copy whatever data could be coppied to another hd and I only got 1TB, 3tb of data was unreadable.

I formatted the drive (quickformat) and now Disk management only sees it as 3TB.

By the wayI used the Data Lifeguard tests:

Quick test passed

Extended test passed

SMART passed

I checked for bad sectors by a different program ana dthere are none!!

I don’t know what happened to this drive.

Once I get this upto 4TB I will use a recovery program to recover the data.

I also used the DOS utility and did only the Quick Write Zeros, it is still at 3TB

If I connect this drive via a ext SATA dock I see only 1TB :slight_smile:

I searched the internet and I saw HDA2 (I think this is manual and I need to enter the size manuıally?? and HDD Capacity Restore tools (doesn’t work on win7 I suppose)

Can someone help?

you say that you will use recovery program to recover the data  but still you tried to write quick write zeros

how will you recover the data if you are using that kind of tool?

@jayjayaa, you appear to have done a lot of damage to your file system. If you do manage to recover your data, it will be DESPITE formatting your drive, not BECAUSE you formatted it. You should never write to a file system that you are trying to recover unless you understand exactly what you are doing.

I suspect that the original problem may be due to a bug in your motherboard’s BIOS. Some Gigabyte boards and also some Asus boards have a bug that results in the drive’s capacity being truncated by 1TB. This happens when the BIOS tries to write a backup copy of itself to the end of the user area, and then reduces the capacity of the drive by a corresponding amount. Unfortunately the bug miscalculates the drive’s capacity.

GigaByte BIOS bug results in loss of 1TB capacity:

Actually I  found out that the hpa was activated probably because of the Bios bug you mentioned. I changed the drive size using HDAT2 software, set it to max and now it is 4TB Now I am trying to recover, let’s see how much I can recover.

Most recovery programs can not even find the drive to recover so whenever a data loss happens what I ussually do is do a quick format and then the recovery program recovers from the formatted drive.

Thank you

try file scanvenger 4.2