402018 Error when trying to restore from safe point

Hello everyone,

 MyCloud 3TB died(red light). RMA replacement arrived. Firmware updated(.421) and static IP set. Everything returned to normal. Plugged in MyBook 3TB drive, select “restore from safepoint”, and this is the error I get when I click finish"This safepoint operation is not allowed. (402018)". 

 Any suggestions? Thanks!

You could dig through the Directories of the safepoint, until you get to “Shares”, and copy over the files to your MyBook without restoring your safepoint … all the data is in there.

Yeah…I think that’s what I’m going to have to do. Thanks for the help. This product could be so good…if it worked.

When I got my 3TB MyCloud 5 days ago, while almost empty, I have tried creating Safepoint to attached USB3 Lexar flash drive. Creation finished ok. Immediately after that I’ve tried to restore that single Safepoint, and ended with same error 402018.  

Since then I have downgraded from ver.4 to ver.3, repeated above procedure and AGAIN ended with error on restore.

But, browsing with WinSCP through directories on MyCloun, in /var/log/apache2 there is file error.log, with many lines but one seems important for restore  “Status: NOTALLOWED; 306393714756616982010425033876833632793: NAS is not in factory-fresh state; restore from safe-point is not-allowed”

So maybe for restore process to work we first have to reset MyCloud. I did not do that nor I wish to try. 

Manual on page 97 

“The Recover section enables you to restore your data from a safepoint to a factory-fresh WD My Cloud device.”

but I did not understand that as it will restore ONLY to clean device. My mistake.

As your replacement drive is new, try factory reset and then go directly to Recover procedure.