320 gb Western Digital Caviar Blue


#1

I have a 320 gb WD caviar blue drive that i have used in my computer for about a year and half to two years.  it worked fine and all but i upgraded to a seagate 1tb drive and put the wd in a external enclosure, and now the wd has some problems. 

when i pluged it in and tried to format it, it told me FAT32 was default, and it only let me use 32 gb to format it.  i know 32 gb is the max for FAT32.  but why is it on fat 32 in the first place.    can anyone help me?  and if this isn’t the right place for this forum, im sorry and please move it.


#2

It is possible that your external enclosure may be causing an issue. I recommend simply deleting all of the partition on the drive and reformatting it to NTFS. If you need it in a FAT32 file system, then you should be able to use a third-party partitioning utility to format the drive in one large FAT32 partition.

Link: How do I partition and format a hard drive (from unused space) for use in Windows

If you have some unusual erroneous data written to the master boot record, then you may need to Write Zeros to the drive using our Data Lifeguard Diagnostics utility.

Link: How do I write zeros to (erase) a WD external hard drive from within Windows?