3 TB spins up but does not connect to computer


#1

I have had the My Book for about 2-3 weeks now. I was transferring files from my computer to it and when I came back it was disconnected but still had power to it. Now it won’t even connect anymore, it still spins up and powers on and all that stuff. It does not connect at all I tried different cable and power cable as well. The computer does not recognize it in disk management as well. Another weird thing about it is when i power it down it will just power right back up in a few seconds with out me pressing the power button. Does anybody know how I can get the computer to read it again?

Thanks


#2

Hi there, if the drive is not on disk management then what if you try a firmware update?


#3

Hello, I have this exact same problem.

I tried the firmware update and with leaving only the external hard drive plugged in it would not recognize the device and therefore the scan was not a success. I tried this multiple times and I’ve had no success. What else can I try?