3.0TB WD Green Shows up as 746GB

Hi all,

Hopefully someone can help me.

I bought a 3TB WD Green with plans to use it as a external storage connected by USB. However it shows upp as 746GB. Since google is my friend, I’ve found several fixes for this but none of them seem to work.

What I have done:

  • I have converted the disk to GPT but it still shows as 746GB

  • I have installed intel RST thing that but it does not find my disk at all.

  • I have tried using Asus Disk Unlocker and tried to use the disk as ywo seperate MBT disks (as instructed)

  • I should not have any problems with old BIOS since the PC is relatively new.

I have Windows 8, which is peculiar since almost all other problems similar to this is contributed to older OS.

I am not a computer-wiz but I have never been stuck on a problem like this that I COULD NOT get Google to help.


Take a look at this link.

Installing a WD SATA, SAS, or PATA drive in an external USB/NAS enclosure or Personal Video Recorder 

I got it to work.

I updated the software from my dockingstation which was quite old.

This enabled me to access the whole disk.