3.04.17 causes TV picture to flash on and off

I’ve reported this as an issue but am curious to know if anyine else has this problem? It’s an odd one - the flashing started during the reboot phase and persisted until I rolled back to 3.03.16. I tried 3.04.07 later that day and it went fine. But only for a while - later that night I went to play a movie and the screen flash had returned. So now I’m back to 3.03.16.

It does it only during movie playback?   What’s the format of the movie?  Were you using subtitles?

Hi Tony. No, the flashing occurred even if just the WD menu page was displayed.

FWIW - Mine has done this once in a while from FW V2.04 all the way to V 3.04.17. I’ve never been able to confirm it’s the Hub’s problem. I always thought it was my Samsung TV having problems with HDMI. If I change the input from HDMI to tuner (not one of the other HDMI ports) and then come back to the Hub’s HDMI input all was fine, until the next time it might happen. Sometimes I get a warning it will happen as the entire screen will flash pink. Then I know I’m going to be switching inputs.

Thanks for that. An odd one indeed. All I know is, all previous versions have been stable for me so I’ll leave the new release alone. Until the next one comes along…

I had a similar issue and it turned out to be a dodgey hdmi cable.

Stealthdude wrote:

I had a similar issue and it turned out to be a dodgey hdmi cable.


I wish…I tried 5 different cables all with the same results. But it only happens to me once in a while and because I see the same thing happening on my PS3 HDMI input I’m pretty sure it’s a Samsung TV issue. No switches in the mix either…right out the back of the device and into the HDMI ports is the way mine are done.

Hello Mate,

Just to be completely sure did you check with another HDMI cable?

No, I can’t see that’s the poblem given that it’s still working fine now that I’ve ‘rolled back’.

Now that you’ve rolled back, what resolution is your WDTV selecting?

What resolution does it select when you’ve upgraded?

Hi Tony. Well now, that’s interesting – I’ve not played around with these settings before. It was set to HDMI/Auto.

I reinstalled the new firmware and the flashing was back. My TV manual tells me it’s 1080p/50Hz but the Hub wouldn’t accept that so I selected 1080i/50Hz. Not only did the flashing cease but the menu screen is much sharper. Excellent stuff. Assuming it stays that way (I thought I had successfully installed 3.04.17 before but it didn’t last) then you have my utmost admiration and gratitude.

(You ask ‘what resolution is your WDTV selecting?’ Surely it’s for ME to tell IT what to select??)

All the best. 

I was more curious if you have the WDTV set to “AUTO,” it will try to find the “best” resolution your TV supports and automatically set it to that.

For example, on OLD firmware (prior to 3.04.17)  on my TV, the Hub would select 720p60 as the “best.”

Now with 3.04.17, the Hub selects 1080p60, which actually IS the best.

Thanks for that. I’m a little confused though - if I set Video Output to Auto and then switch off the Hub how do I know which resolution the Hub has chosen? Because next time I access the Video Output menu, it’ll still say Auto.

You wouldn’t know if you switch off the Hub.

Most TVs will tell you what the current resolution is active on HDMI sources.   Not all, though…

For example, my LG TV will pop up an info banner that says “1080p60” or “1080p24” or whatever when I press the SELECT button on the remote.

I get you now. I’ve an LG myself and although it’s officially 1080p I don’t think I’ve ever watched a channel that was better than 1080i. Maybe a bluray might show 1080p but I don’t have that.

Anyhoo, it’s still odd that this latest firmware doesn’t work properly (for me) on the Auto setting. But, thanks to your post which prompted me to fiddle with the settings, I’m now more than happy.

All the best to you.