2x WD MyBook Elite 1TB drives not being recognized at the same time


#1

Hi There,

I have just recently purchased two WD MyBook Elite 1TB drives. They both work perfectly fine (individually) when plugged into my computer.

When both of them are plugged in at the same time, only one drive is shown in “My Computer”. Both the drives “virtual cd” icons appear for the WD SmartWare software, but only one physical drive is shown in My Computer.

If I disconnect the one that is showing and then reconnect the one that wasn’t showing, then this one starts to show - But again, when connecting the second one, the second one does not show.

I’ve tried swapping the USB cables between them, and the power adaptors - But it makes no difference.

Each USB cable works fine on its own individual drive, and same with the power adaptors. But when connecting both drives to the computer they both don’t work (only the first one is visible)

I’ve also tried deleting it from Device Manager and then scanning for new hardware to install the drives again, but that doesn’t work either.

Please let me know what I need to do to get them to recognize at the same time.

Cheers,

Nick


#2

With them both connected go into disk management and asssign the second a drive letter and change it to online.

Joe


#3

You, my friend, are a legend!

I was going to reply saying that I have already tried that but I never tried changing it to “online”. I had only looked at the list at the top which didn’t show the second drive… But alas, when I scrolled down to the bottom it revelaed both drives one with “offline”.

Worked perfectly. I’ll be sure to do as instructed for the second bit.

One last question - Will I have to do this with every computer the drive gets connected to, or will it be fine from now on?

Cheers


#4

I don’t know about new drives but it should be fine now. At least you know wher to look! The online part took me a while to figure out too.

Joe