2x WD essential recognised as one


#1

hello guys… i just bought my second WD my book essential 1TB just to back up everything that i already have on my other one… both drives are identical but when i plug in both of them it only appears one of them in ‘‘my computer’’… when i connect just one (no.1 OR no.2), they both appear in each occation… but i need to see them both so i can transfer from one to the other directly and not copy from no.1 to my pc and then from my pc to to no.2. They both appear like drive J: so i tried renaming just one of them to a different letter but still nothing works… They both appear as the different letter now but in ‘‘my computer’’ shows only the one that is connected faster than the other…

They both have been updated as well as the wd software.  It seems that pc software identifies both as the same drive and not as no.1 & no.2!

I’m out of options

Please help!

Note: I use for both connection via usb 2.0, i run O.S Win 7 64bit

thank you in advance… 


#2

Try renaming one of the drives.  Before connecting them both.


#3

Hah, I also have the same problem, but mine is 2TB x 2 :stuck_out_tongue:


#4

Have you solved this issue?  I’m having the same problem.  Thanks in advance!


#5

it doesnt work. renaming just the letter drive or the name of the drive still no solution… any more suggestions? thank you… 


#6

no solution yet… as soon as I have one I’ll post it but its a stupid problem…this should never happen…


#7

Hi yeah same problem here. 

had one Mybook 2TB works fine called it media1 and then bought another today and called it Brian’s Media. When I plug them both in, I can only see one…but you can see both cd drives that the mybook creates. 

Really annoying. 

Hope a fix comes soon. Or if I find a fix…i’ll let you know. 


#8

btw I’m on windows 7. Dont know if that makes a difference. 


#9

ok decided to email WD instead and got  swift response. 

Simply go to the disk managment in windows. the drive will appear as offline, right click and click on online. This is a windows problem and not a WD problem. 

in windows 7 i had trouble finding it, in the search bar type disk and choose the option that says disk partition and formatting. scroll the to the bottom of the page and you will find it. 

Cheers