2TB My Book taking 10+ mins to load root dir

I have a less than year old 2 TB My Book that has about 1 TB occupied with mostly video files. Sometime last week, while the drive was NOT being accessed, the power plug was accidentally dislodged from the outlet. I replugged, checked the drive, things seemed fine. Yesterday I tried to access the drive from my computer and explorer then says not responding. I kept closing the window and having explorer restart. I tried unplugging, replugging, restarting, shutting down, switching USB ports. I had set it’s files to share on an XBOX, I disabled that. I ran windows update. I was able to right click on the drive in my computer and scan for errors, this scan lasted around 6+ hours, scanning over 3,000 files, except I don’t think there’s that many files on there. Maybe between 1000-1500 or so. It finished while I was away from my laptop so I don’t know if it came up with anything. I finally got access to the files on the disc in explorer but just letting it sit after clicking on the drive. In about 10 minutes I was in the main directory where most of the files are. Is loading the thumbnails for all those video files causing problems? But I’ve had this many files for awhile. Also on Vista I often get these COM surrogate errors when trying to load many thumbnails but I just close them and can access things just fine. I thought loading the thumbnails might be the or 1 of the problems so with access to the main directory I went to customize folder and have things show as documents instead of pictures and video. It’s been working on this for the past 30-40 minutes and I’m wondering if it’ll ever finish or make any difference. I have the drive indexed for faster searching, should I uncheck that? I tried using Gyula’s Navigator to access the drive but couldn’t, but as I said the data is all still there as evidenced when I let explorer work and slowly open the directory. I copied a video file over to the drive a few days ago when the drive was still functioning normally. It didn’t show up symetrical in the drive, kind fo stuck in between 2 other thumbnailed files, I guess I don’t have auto align set, but that wouldn’t cause these problems would it? I could try refreshing or resorting but as I said there’s so much content there and the drive is being so unusably slow I hesitate to bother with any of that if that’s not the root of the problem. Would defragmenting or running disk cleanup possibly alleviate these issues? Looking for any help here, I have 1 year’s worth of data on this drive.

*UPDATE* The process of changing the folder options from pictures and video to documents so no thumbnails load completed, and I am now able to access the drive instantly, pointing to the thumbnail issue as the main culprit seemingly. However as I said I’ve had about this much data on the drive for quite some time and was previously able to load into the drive fine even with all the thumbnails, so any advice on how to have that functionality would still be appreciated though I am glad just to have all the data intact and accessible.

WOW, You are lucky, I have a similar problem.
I have it plugged in through a surge protector and the power went out.
since then when I plug it in, the only thing I can do is Unlock it. and once I unlock it. My computer seems to stop working. I can’t even access the internet. and I have 4Gb of ram and to open My Documents takes like 1-2 mins.
I’ve tried every thing you have wrote that I am able to do but as for getting rid of the thumbnails I can’t even get that far because when I go to open My Book, it tells me that Explorer has encountered an error and needs to shut down.
then it asks me to either shut down  or shut down and restart.

I’m starting to lose it with this. I have VERY important documents, programs and pictures of my son when he was first born. and I can’t even get to any of it anymore.

I still haven’t found a soloution but I’m still looking, I’ll update if anything changes. 

Sounds like your worse off than me.

I have an update on my situation. Still having problems. I had the harddrive up and running, and in the midst of activity, it seems to have lost contact with my computer. It no longer shows up in my computer, it’s like it can’t keep the USB connection. There’s a port that is most convenient for me to have it on, that I know works because I’ve plugged my mouse into it. I just tried unplugging, replugging, and plugging the adapter directly into the outlet (I use a small 6 outlet surge box) and the drive just won’t power up. What is the issue? I have a AC adapter for another WD 1TB I have, would it be safe to try using that plug with this 2 TB to see if it’s something with my AC cord?

Capture.PNGIt just got worse too.

I click the CD Drive (H:) WD Ulocker
And now it gives me this error. 

Capture1.PNG

I have no I dea what to do Anymore… For the cost of hardware and the Digitaly purchased software that is on there. I’m losing Easily $500.00 

I really hope someone can figure something out for me.
I’m still trying but I’ve been Trying since 10:00AM and it is now 8:45PM (Not constantly trying but often).
And it’s about time I get to bed.